Bug 483042 - Fonts in wine apps look ugly after update
Fonts in wine apps look ugly after update
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2009-01-29 09:03 EST by Thomas M Steenholdt
Modified: 2009-12-18 02:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 02:44:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
winemine license window running wine 1.1.12-1 (10.69 KB, image/png)
2009-01-29 09:03 EST, Thomas M Steenholdt
no flags Details
winemine license window running wine 1.1.10-1 (24.83 KB, image/png)
2009-01-29 09:04 EST, Thomas M Steenholdt
no flags Details
winemine license window running 1.1.12-1 but looking good (different machine) (10.08 KB, image/png)
2009-01-29 14:40 EST, Thomas M Steenholdt
no flags Details

  None (edit)
Description Thomas M Steenholdt 2009-01-29 09:03:20 EST
Created attachment 330352 [details]
winemine license window running wine 1.1.12-1

Description of problem:
Ever since my wine packages were updated from 1.1.10 to 1.1.12, fonts have been looking crappy. Downgrading to 1.1.10 makes things look all right again.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. run winemine and notice the appearance of the fonts
2. update wine packages to 1.1.12-1
3. run winemine again and notice the appearance of the fonts are now crappy
Actual results:
fonts look crappy

Expected results:
fonts should look nice, still

Additional info:
Comment 1 Thomas M Steenholdt 2009-01-29 09:04:03 EST
Created attachment 330353 [details]
winemine license window running wine 1.1.10-1
Comment 2 Andreas Bierfert 2009-01-29 11:04:21 EST
I am very sorry but I am not able to reproduce this at all. My window looks exactly like your attachment even so I am running on 1.1.12.

Could you try the old trick of moving ~/.wine to ~/wine-old and see what happens with a fresh wine directory?

Also see https://bugzilla.redhat.com/show_bug.cgi?id=481248 this might be related.
Comment 3 Thomas M Steenholdt 2009-01-29 14:27:49 EST
I should have already mentioned this in the first post. I have rm -rf'ed ~/.wine several times and unfortunately, it doesn't change this problem.

Actually I have a quite similar machine that also looks quite nicely with 1.1.12-1, although it's appearance is still not identical to that of 1.1.10-1.
To me, it looks like 1.1.10-1 uses some sort of font-smoothing where 1.1.12-1 does not. On my "working" machine, fonts are not smoothed either, but for some reason they are rendered a whole lot nicer. I'll attach a screenshot in a minute.
Comment 4 Thomas M Steenholdt 2009-01-29 14:40:20 EST
Created attachment 330395 [details]
winemine license window running 1.1.12-1 but looking good (different machine)
Comment 5 Thomas M Steenholdt 2009-01-29 15:04:25 EST
There is no doubt in my mind that the problems have come with changes in the way, wine renders it's fonts (smoothed in 1.1.10 vs non-smoothed in 1.1.12).
The question is, which is the correct. When the non-smoothed font-rendering works, it actually looks very well (like a normal windows machine). But it appears to be a whole lot harder to get it right.

Having installed ms corefonts on my machines screwed the basic application fonts up. After removing that package, the winmine license window looks like that of the other machine.

However, I'm running IE (installed with ies4linux) and even though the IE application font looks just as well as the winmine (still not smoothed), the content of the webpages looks just as crappy as the applications did earlier.
Comment 6 Ralf Kleineisel 2009-02-07 13:49:52 EST
I experienced this bug in my machine, too. Downgrading to 1.1.7 helped.
Comment 7 Thomas M Steenholdt 2009-03-12 07:23:55 EDT
1.1.10-1 is still the latest version from Fedora, that looks properly. I just tried the latest 1.1.15-1 packages, but fonts with this version are jagged and ugly too...
Comment 8 Thomas M Steenholdt 2009-03-26 17:12:06 EDT
Hi there. I found this page, that helped me enable FontSmoothing in the latest fedora update og wine and now things are okay.


So the real "bug" here seems to be a new default behaviour?
Comment 9 Fernando Herrera 2009-03-28 11:33:09 EDT
I had the same problem using a fresh install of Fedora 10. Adding those reg entries mentioned on #8 fixed the problem.
Comment 10 Julian Sikorski 2009-06-21 06:43:33 EDT
Upstream bug:
Comment 11 Bug Zapper 2009-11-18 05:54:28 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 12 Bug Zapper 2009-12-18 02:44:02 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.