Bug 483044 - Generation of /var/log/rpmpkgs cannot be turned off
Generation of /var/log/rpmpkgs cannot be turned off
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 09:20 EST by Radu Rendec
Modified: 2009-05-14 04:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 04:05:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against /etc/cron.daily/rpm (383 bytes, patch)
2009-01-29 09:20 EST, Radu Rendec
no flags Details | Diff
Example /etc/sysconfig/rpm (11 bytes, text/plain)
2009-01-29 09:21 EST, Radu Rendec
no flags Details

  None (edit)
Description Radu Rendec 2009-01-29 09:20:58 EST
Created attachment 330354 [details]
Patch against /etc/cron.daily/rpm

Description of problem:

The rpm package automatically deploys /etc/cron.daily/rpm, which in turn triggers /bin/rpm -qa. Since this file is not declared as %config in the spec file, there seems to be no safe way to disable this.

Since the rpm bdb backend is known to cause deadlocks from time to time (especially on concurrent query/update of the package database), automatically firing rpm -qa is not only annoying but also potentially dangerous (for instance if it fires during yum upgrade).

Version-Release number of selected component (if applicable):

Tested on rpm-4.6.0-0.rc3.1.fc10.i386, but in actually applies to all versions, at least from fedora 8 up to current versions.

Additional info:

Suggest using /etc/sysconfig/rpm (or something similar) to define a variable that enables/disables generation. Suggested patch attached.
Comment 1 Radu Rendec 2009-01-29 09:21:58 EST
Created attachment 330355 [details]
Example /etc/sysconfig/rpm
Comment 2 Panu Matilainen 2009-05-14 04:05:30 EDT
Thanks for the patch, but instead of adding rather RH-specific /etc/sysconfig/ stuff into the scripts, the cronjob is split now into a sub-package in rawhide so you can just 'rpm -e rpm-cron' if dont want it. Not going to happen for F10 though.

Note You need to log in before you can comment on or make changes to this bug.