Bug 483056 - RFE: Support SHA-256
RFE: Support SHA-256
Status: CLOSED DUPLICATE of bug 1126713
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: fedora-sha2
  Show dependency treegraph
 
Reported: 2009-01-29 10:06 EST by Miloslav Trmač
Modified: 2014-08-22 07:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-22 07:39:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2009-01-29 10:06:46 EST
rsync currently uses MD4 or MD5 for comparing files and file chunks.  There are known attacks attacks against both hashes, we should add support for SHA-256.  See https://fedoraproject.org/wiki/Features/StrongerHashes for more information and more detailed rationale
Comment 1 Matt McCutchen 2009-11-27 21:30:12 EST
I would suggest pursuing this in combination with bug 348161.
Comment 2 Fedora Admin XMLRPC Client 2010-10-05 07:59:47 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2012-05-07 05:31:49 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Michal Luscon 2014-08-22 07:39:36 EDT

*** This bug has been marked as a duplicate of bug 1126713 ***

Note You need to log in before you can comment on or make changes to this bug.