Bug 483080 - Prompted for text-mode or VNC even when providing the preference already (cmdline or ks)
Prompted for text-mode or VNC even when providing the preference already (cmd...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 11:25 EST by James Laska
Modified: 2013-09-02 02:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 06:17:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (7.15 KB, text/plain)
2009-01-29 11:25 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2009-01-29 11:25:14 EST
Created attachment 330373 [details]
anaconda.log

Description of problem:

Prompted for VNC or text-mode preference, even when I provide the preference via cmdline or kickstart

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot with "console=ttyS0 text serial method=http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os"
2. Enter lang and keyboard preference
3. Entry Install method (URL)
  
Actual results:

             ┌───────────┤ Would you like to use VNC? ├───────────┐
             │                                                    │
             │ Text mode provides a limited set of installation   │
             │ options.  It does not allow you to specify your    │
             │ own partitioning layout or package selections.     │
             │ Would you like to use VNC mode instead?            │
             │                                                    │
             │     ┌───────────┐          ┌───────────────┐       │
             │     │ Start VNC │          │ Use text mode │       │
             │     └───────────┘          └───────────────┘       │
             │                                                    │
             │                                                    │
             └────────────────────────────────────────────────────┘

Expected results:

Should not prompt for preference if already supplied in ks.cfg or cmdline

Additional info:
 * see anaconda.log
Comment 1 James Laska 2009-01-29 11:35:35 EST
Additional info:
 * Booting with "vnc" on the cmdline starts VNC mode without prompting
 * Using a kickstart with the "text" cmd proceeds with text mode without prompting
Comment 2 Martin Sivák 2009-02-02 06:55:55 EST
This is expected behaviour. Kickstart choice is obeyed, but since the only way of  manually starting the text mode without KS is through the "text" cmdline option, the question should be displayed.

Otherwise the question would never ever be displayed (this was the situation before we introduced our plans to prefer VNC over text mode).
Comment 3 James Laska 2009-02-02 10:09:08 EST
I'm confused ... I've booted with "text" and it still asks if I want text of VNC.  If I boot with "vnc", it does not ask.  It seems I should only be prompted 

I'd like for this bug report to reflect either:
 1) honoring the "text" cmdline request (as we do for "vnc" cmdline)

 2) or remove "text" as a supported boot option
Comment 4 Martin Sivák 2009-02-03 06:17:45 EST
Text command line option is the only way how to get the question (because it is also the only way how to ask for text mode without kickstart). We are not removing text mode, but we strongly prefer VNC.

So we cannot honor the text command line option, because we decided we really want to ask the question. And we cannot remove it either, you are still able to use text in interactive mode if you want to. Just use the right answer in the question dialog.

If your goal is unattended instalation, use kickstart command to set the text mode, you won't get any question about vnc that way.

Note You need to log in before you can comment on or make changes to this bug.