Bug 483095 - Clicking a button in Java applet causes Firefox crash
Clicking a button in Java applet causes Firefox crash
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
http://www.propublica.org/special/sti...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 12:25 EST by Robin Green
Modified: 2009-06-02 10:31 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.6.0.0-18.b16.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 10:08:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
session captured with script -c 'firefox -g' command (19.52 KB, text/plain)
2009-02-04 13:22 EST, Robin Green
no flags Details

  None (edit)
Description Robin Green 2009-01-29 12:25:35 EST
Description of problem:
Firefox crashes reproducibly when I click on a button in a particular applet.

Version-Release number of selected component (if applicable):
firefox-3.1-0.4.beta2.fc11.i386

How reproducible:
Always

Steps to Reproduce:
1. Go to URL above
2. Click on "click to interact". This will start the applet.
3. Applet will display an error message, and a button to report the error back to the website. Click the button.
  
Actual results:
Firefox crashes

Expected results:
No crash

Additional info:
java-1.6.0-openjdk-1.6.0.0-8.b14.fc11.i386
java-1.6.0-openjdk-plugin-1.6.0.0-8.b14.fc11.i386

This is in VirtualBox 2.1.0 OSE on Mac OS X. I am unable to use GDB to debug firefox due to an issue with VirtualBox, which I am about to report.
Comment 1 Matěj Cepl 2009-02-04 10:45:34 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Robin Green 2009-02-04 13:22:24 EST
Created attachment 330900 [details]
session captured with script -c 'firefox -g' command

plymouth-plugin-solar-0.6.0-2.fc11.i386
nspluginwrapper-1.3.0-2.fc11.i386
anaconda-yum-plugins-1.0-3.fc10.noarch
xulrunner-debuginfo-1.9.1-0.7.beta2.fc11.i386
nspluginwrapper-debuginfo-1.3.0-2.fc11.i386
gstreamer-plugins-flumpegdemux-0.10.15-4.fc10.i386
xulrunner-1.9.1-0.7.beta2.fc11.i386
gstreamer-plugins-good-0.10.13-2.fc11.i386
firefox-debuginfo-3.1-0.4.beta2.fc11.i386
plymouth-plugin-label-0.6.0-2.fc11.i386
firefox-3.1-0.4.beta2.fc11.i386
gstreamer-plugins-base-0.10.22-1.fc11.i386
mozilla-filesystem-1.9-2.fc9.i386
PackageKit-yum-plugin-0.4.3-1.fc11.i386
alsa-plugins-pulseaudio-1.0.18-2.fc11.i386
mozilla-filesystem-1.9-2.fc10.i386
java-1.6.0-openjdk-plugin-1.6.0.0-10.b14.fc11.i386
PackageKit-gstreamer-plugin-0.4.3-1.fc11.i386
plymouth-plugin-spinfinity-0.6.0-2.fc11.i386

I used the command
script -c 'firefox -g'
instead of just firefox -g, to capture the backtrace, so I also got the Java backtrace(s) included in the attachment as well.
Comment 3 Matěj Cepl 2009-02-05 10:25:14 EST
This not a Firefox bug -- java plugin crashed and took firefox with itself.

Reassigning to java components.
Comment 4 Deepak Bhole 2009-03-04 18:34:50 EST
The problem was with the plugin. The applet made a showDocument() call with a url that had a newline, and that caused parsing problems and crashed the plugin. I have fixed it upstream. I'll close this bug when it gets into Fedora.
Comment 5 Fedora Update System 2009-05-30 10:16:12 EDT
java-1.6.0-openjdk-1.6.0.0-18.b16.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-18.b16.fc10
Comment 6 Fedora Update System 2009-05-30 10:17:08 EDT
java-1.6.0-openjdk-1.6.0.0-22.b16.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-22.b16.fc11
Comment 7 Fedora Update System 2009-06-02 10:22:54 EDT
java-1.6.0-openjdk-1.6.0.0-22.b16.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-06-02 10:30:31 EDT
java-1.6.0-openjdk-1.6.0.0-18.b16.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.