Bug 483134 - move selinux to /usr/share/selinux/modules
move selinux to /usr/share/selinux/modules
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: SELinux (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ade Lee
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-01-29 15:03 EST by Ade Lee
Modified: 2015-01-04 18:36 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ade Lee 2009-01-29 15:03:41 EST
Description of problem:

To prevent conflicts, move selinux to /usr/share/selinux/modules

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ade Lee 2009-01-29 15:07:14 EST
spec file changes .. mharmsen, please review.

Index: dogtag/selinux/pki-selinux.spec
===================================================================
--- dogtag/selinux/pki-selinux.spec     (revision 201)
+++ dogtag/selinux/pki-selinux.spec     (working copy)
@@ -33,7 +33,7 @@
 ## Package Header Definitions
 %define base_name         %{base_prefix}-%{base_component}
 %define base_version      1.0.0
-%define base_release      3
+%define base_release      4
 %define base_group        System Environment/Shells
 %define base_vendor       Red Hat, Inc.
 %define base_license      GPLv2 with exceptions
@@ -169,8 +169,8 @@
 rm -rf ${RPM_BUILD_ROOT}
 mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/doc/%{base_name}-%{base_version}
 cp -p LICENSE ${RPM_BUILD_ROOT}%{_datadir}/doc/%{base_name}-%{base_version}
-mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/selinux/targeted
-cp -p src/pki.pp ${RPM_BUILD_ROOT}%{_datadir}/selinux/targeted
+mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/selinux/modules
+cp -p src/pki.pp ${RPM_BUILD_ROOT}%{_datadir}/selinux/modules
 
 
 
@@ -209,7 +209,7 @@
 %saveFileContext targeted
 
 %post
-semodule -s targeted -i /usr/share/selinux/targeted/pki.pp 
+semodule -s targeted -i /usr/share/selinux/modules/pki.pp 
 %relabel targeted
 
 %preun
@@ -229,7 +229,7 @@
 
 %files
 %attr(-,root,root)     %{_datadir}/doc/%{base_name}-%{base_version}/*
-%attr(-,root,root)     %{_datadir}/selinux/targeted/pki.pp
+%attr(-,root,root)     %{_datadir}/selinux/modules/pki.pp
 
 
 
@@ -238,6 +238,8 @@
 ###############################################################################
 
 %changelog
+* Thu Jan 29 2009 Ade Lee <alee@redhat.com> 1.0.0.4
+- Bugzilla Bug #483134 Moved selinux to /usr/share/selinux/modules
 * Tue Jan 27 2009 Ade Lee <alee@redhat.com> 1.0.0-3
 - Bugzilla Bug #482738 - selinux changes required for cloning
 * Tue Jan 20 2009 Matthew Harmsen <mharmsen@redhat.com> 1.0.0-2
Comment 3 Matthew Harmsen 2009-01-29 17:08:25 EST
Comment #1:  +mharmsen
Comment 5 Ade Lee 2009-01-29 17:14:25 EST
[builder@dhcp231-124 selinux]$ svn ci -m "Bugzilla Bug #483134 Moved selinux to /usr/share/selinux/modules" 
Sending        selinux/pki-selinux.spec
Transmitting file data .
Committed revision 203.
Comment 7 Jenny Galipeau 2009-06-05 12:00:05 EDT
Looks like it is in a few locations?

[root@qe-blade-11 /]# find / -name pki.pp
/usr/share/selinux/targeted/pki.pp
/usr/share/selinux/modules/pki.pp
/etc/selinux/targeted/modules/active/modules/pki.pp
/etc/selinux/targeted/modules/previous/modules/pki.pp
Comment 8 Ade Lee 2009-06-05 14:22:41 EDT
That is ok.

the last two are artifacts from the installation process.  These are not used and can be ignored.

The first one is delivered by the selinux-policy-targeted rpm, but is not used/activated by that rpm.

A separate bug should be opened and assigned to dwalsh to remove this (unactivated) file.
Comment 9 Jenny Galipeau 2009-06-05 14:42:04 EDT
bug file and assigned to Dan https://bugzilla.redhat.com/show_bug.cgi?id=504353
Closing bug verified.

Note You need to log in before you can comment on or make changes to this bug.