Bug 483154 - Add IOCTL support for EMC Symmetrix control functions to dasd subsystem
Add IOCTL support for EMC Symmetrix control functions to dasd subsystem
Status: CLOSED DUPLICATE of bug 461288
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
s390x Linux
low Severity high
: alpha
: 5.4
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 16:03 EST by Nigel Hislop
Modified: 2009-02-27 21:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 21:24:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add IOCTL support for EMC Symmetrix dasd (5.10 KB, patch)
2009-02-27 16:06 EST, Nigel Hislop
no flags Details | Diff

  None (edit)
Description Nigel Hislop 2009-01-29 16:03:04 EST
History:
EMC developed a "loadable" ioctl module for kernel level 2.6.16 which loaded into the kernel the functionality required for Symmetrix control I/O to issued. This was accomplished via a CKD specific dasd ioctl.
However, the ioctl dynamic load functions were removed in kernel 2.6.17, so EMC requires the equivalent IOCTL capability in the RHEL5 5.4 kernel.

This IOCTL functionality has already been accepted upstream into the Linux kernel at 2.6.28. Refer to the 2.6.28 git patch at:
http://preview.tinyurl.com/awncad
or
http://git390.osdl.marist.edu/cgi-bin/gitweb.cgi?p=linux-2.6.git;a=commit;h=ab1d848fd6a9151b02c6cbf4bddce6e24707b094

In order to fully support Symmetrix CKD devices on RHEL 5.4, we require this upstream patch merged the RHEL 2.6.18 kernel.
The patch will need to be modified from the upstream patch, so EMC will modify the patch and test it on RHEL 5.2 and then make it available via this BZ.
Comment 1 Nigel Hislop 2009-02-25 19:32:33 EST
The patch has been built and tested on a RHEL 5.2 system. It was added to the SPEC file for the kernel build.
It has very minor changes as compared to the upstream code. I'll upload the patch for inspection in a few days.
Comment 2 Nigel Hislop 2009-02-27 16:06:10 EST
Created attachment 333537 [details]
Add IOCTL support for EMC Symmetrix dasd
Comment 3 Andrius Benokraitis 2009-02-27 21:24:06 EST

*** This bug has been marked as a duplicate of bug 461288 ***

Note You need to log in before you can comment on or make changes to this bug.