Bug 483194 - mount.nfs selinux denial with 2.6.29-0.6.rc3.fc10.x86_64
mount.nfs selinux denial with 2.6.29-0.6.rc3.fc10.x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 01:45 EST by Jason Tibbitts
Modified: 2009-10-26 11:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 11:14:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Tibbitts 2009-01-30 01:45:00 EST
After booting 2.6.29-0.6.rc3.fc10.x86_64 slurped from koji, the following selinux complaint appears exactly three times when autofs mounts my home directory:

type=1400 audit(1233297178.744:4): avc:  denied  { signal } for  pid=1711 comm="mount.nfs" scontext=system_u:system_r:rpcd_t:s0 tcontext=system_u:system_r:mount_t:s0 tclass=process

This does not appear when I boot back into the current 2.6.27 kernel.
Comment 1 Daniel Walsh 2009-01-30 08:44:45 EST
I believe this is a kernel issue since I have a hard time believing a daemon is sending a signal back to the mount command.
Comment 2 Vedran Miletić 2009-10-26 10:55:53 EDT
Reporter, can you retest this to see if this was fixed in the meantime?
Comment 3 Jason Tibbitts 2009-10-26 11:14:57 EDT
I no longer have any F10 machines available for testing; I don't recall that I've seen this with F11 or rawhide in recent memory.  I guess I'll go ahead and close this.
Comment 4 Vedran Miletić 2009-10-26 11:56:04 EDT
Thank you for reporting back.

I believe it would be proper to close it as NEXTRELEASE, since F11 is next release compared to F10.

Note You need to log in before you can comment on or make changes to this bug.