Bug 483223 - openoffice.org writer crashed when trying to print a from letter
openoffice.org writer crashed when trying to print a from letter
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 489124 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 05:42 EST by Kai Hambrecht
Modified: 2009-03-16 15:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.0.1-15.3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 15:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash report when trying to print a form letter (11.13 KB, text/plain)
2009-01-30 05:44 EST, Kai Hambrecht
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 98649 None None None Never

  None (edit)
Description Kai Hambrecht 2009-01-30 05:42:12 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5

I have a odt-document which contains database fields. These fields are inserted from a ods-spreadsheet. When i try to print the odt, openoffive tells tha the document contains database fields an asks if i want to print a form letter. After clicking on "yes" openoffice crashes and prints out a trace. I will attach the trace to this bug report.

Reproducible: Always

Steps to Reproduce:
1. Create an ods with a simple column
2. Create an odt, assign the previously create odt as database
3. Insert database filed from the assigned ods
4. print odt, answer yes to question about form letter
Actual Results:  
openoffice crashes

Expected Results:  
printing a from letter with the assigned database fields.

this happens with both, actual openoffice.org-3.0.0-9.10.fc10 and updates-candidate openoffice.org-3.0.1-15.2.fc10
Comment 1 Kai Hambrecht 2009-01-30 05:44:28 EST
Created attachment 330452 [details]
Crash report when trying to print a form letter
Comment 2 Caolan McNamara 2009-01-30 06:12:50 EST
Hmm, please try this as a workaround

yum install openoffice.org-base
Comment 3 Kai Hambrecht 2009-01-30 06:36:49 EST
that fixed it. Thanks.
Comment 4 Caolan McNamara 2009-01-30 07:47:26 EST
Fix will be in >= 3.0.1-15.3
Comment 5 Caolan McNamara 2009-03-09 12:37:20 EDT
*** Bug 489124 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2009-03-10 10:13:17 EDT
openoffice.org-3.0.1-15.3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/openoffice.org-3.0.1-15.3.fc10
Comment 7 Fedora Update System 2009-03-11 13:55:27 EDT
openoffice.org-3.0.1-15.3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2568
Comment 8 Fedora Update System 2009-03-16 15:38:20 EDT
openoffice.org-3.0.1-15.3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.