Bug 483226 - webcam does not work on eee pc 900
webcam does not work on eee pc 900
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 05:59 EST by Sarantis Paskalis
Modified: 2009-02-13 04:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 08:22:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sarantis Paskalis 2009-01-30 05:59:21 EST
Description of problem:

kernel does not find webcam of eee pc 900. Smolt profile here:
http://www.smolts.org/client/show/pub_709585b1-faaf-492c-ac21-142da001afbd


Version-Release number of selected component (if applicable):
kernel-2.6.27.12-170.2.5.fc10.i686
system fully updated as of today.

How reproducible:

Always.

Steps to Reproduce:
1. launch ucview
2. ucview fails with message "No supported video capture devices found!"
3.
  
Actual results:


Expected results:


Additional info:


this is consistent behaviour from F-9 upwards (not finding webcam).  Note that the linux version pre-installed worked found the webcam just fine, and so did the application (ucview).  (There is no longer the original distro installed)

manual modprobing uvcvideo (as described in 
http://fedoraproject.org/wiki/EeePc#Webcam) succeeds but the webcam is still not detected.
Comment 1 Chuck Ebbert 2009-01-30 16:28:47 EST
Hans, is this camera supported in 2.6.29?
Comment 2 Hans de Goede 2009-02-02 07:21:56 EST
(In reply to comment #1)
> Hans, is this camera supported in 2.6.29?

It should be, the 900 has known hardware problems where it drains the battery even when off, one possible workaround advertised for this is to disable all usb ports in the BIOS, that could be the cause of this.

Sarantis,

Can you:
1) Check that USB is enabled in the BIOS
2) Do: "lsusb" on a terminal and paste the output here
3) Do: "lsusb -n" on a terminal and paste the output here

Thanks!
Comment 3 Sarantis Paskalis 2009-02-02 08:22:36 EST
The camera was disabled in the BIOS.  Enabling it made it work for the first time in Fedora.  The reason I had not checked there before was that the camera worked with the asus-specific distro.

Closing  NOTABUG for now, if you would like the lsusb info anyway, let me know.

Thanks.
Comment 4 Sarantis Paskalis 2009-02-13 04:32:50 EST
As an additional datapoint, the webcam became self-disabled again in the BIOS and it needed manual enabling again.

Note You need to log in before you can comment on or make changes to this bug.