Bug 483228 - Delete key should work in bookmarks sidebar
Delete key should work in bookmarks sidebar
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 06:38 EST by Christopher Beland
Modified: 2009-01-31 16:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-31 16:04:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2009-01-30 06:38:01 EST
After I select a bookmark in the Bookmarks sidebar, I expect to be able to delete that bookmark by hitting the Delete key.  This works in the "Organize Bookmarks" window, but not in the sidebar.

firefox-3.0.5-1.fc9.i386
Comment 1 Matěj Cepl 2009-01-30 12:14:10 EST
Well, actually, it does work for me with firefox-3.0.5-1.fc10.x86_64
Are you able to reproduce with running firefox with -safe-mode option on command line, please?
Comment 2 Christopher Beland 2009-01-30 18:32:16 EST
I have machines running F9 and F10.91 Rawhide, and I can reproduce on the latter with these steps:

0. firefox -no-remote -safe-mode

1. Select by left-clicking "View -> Sidebar -> Bookmarks"

2. Right-click on homepage tab and select "Bookmark this tab"

3. Left click "Done" on the pop-up to put it in the "Bookmarks Menu" folder.

4. Left click on the triangle next to "Bookmarks Menu" in the sidebar.

5. Left click on the line with the homepage's title.  This has the effect of re-loading the page.

6. Hit the Delete (not Backspace) button on the keyboard.  Nothing happens.
Comment 3 Christopher Beland 2009-01-30 18:47:39 EST
That's firefox-3.1-0.4.beta2.fc11.x86_64; I keep forgetting to give version numbers today...
Comment 4 Matěj Cepl 2009-01-31 16:04:13 EST
(In reply to comment #2)
> 5. Left click on the line with the homepage's title.  This has the effect of
> re-loading the page.

I think I know what’s going on and I am closing as NOTABUG here. If I follow your description step by step, I can reproduce the behavior you describe. However, I don’t think it is a bug, it might be questionable, but what happens here is that when you reload the page, the keyboard focus moves to the reloading page itself (i.e., it is not in the bookmark sidebar). So, when you press DELETE the keypress goes to the webpage itself (which does nothing, most of the time).

If you instead of your 5. RIGHT click the bookmark, then press ESC to close the context menu, DELETE works as expected, because focus didn't move out of the sidebar.

As I said closing as NOTABUG. If you don’t agree with the transfer of focus, I have to ask you to deal with it in the upstream bugzilla (http://bugzilla.mozilla.org) — that’s not something we can deal with on the distribution level.

Note You need to log in before you can comment on or make changes to this bug.