Bug 483259 - livecd-creator -b crashes
livecd-creator -b crashes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 10:34 EST by Alexander Todorov
Modified: 2009-07-21 14:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 14:31:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
foss_packages.ks (885 bytes, text/plain)
2009-01-30 10:34 EST, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2009-01-30 10:34:56 EST
Created attachment 330477 [details]
foss_packages.ks

Description of problem:
# livecd-creator -c foss_packages.ks -b ./F10-i686-Live.iso --cache=/var/tmp/livecd/ 
Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 136, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 118, in main
    creator.mount(options.base_on, options.cachedir)
  File "/usr/lib/python2.5/site-packages/imgcreate/creator.py", line 503, in mount
    self._mount_instroot(base_on)
  File "/usr/lib/python2.5/site-packages/imgcreate/live.py", line 178, in _mount_instroot
    LoopImageCreator._mount_instroot(self, base_on)
  File "/usr/lib/python2.5/site-packages/imgcreate/creator.py", line 915, in _mount_instroot
    self._base_on(base_on)
  File "/usr/lib/python2.5/site-packages/imgcreate/live.py", line 134, in _base_on
    isoloop = Mount(LoopbackDisk(base_on), self._mkdtemp())
TypeError: __init__() takes exactly 3 arguments (2 given)

Version-Release number of selected component (if applicable):
livecd-tools-020-1.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. livecd-creator -c foss_packages.ks -b ./F10-i686-Live.iso --cache=/var/tmp/livecd/ 

where the iso is the standard livecd iso, cache directory contains rpm packages and ks file will be attached.
  
Actual results:
Traceback

Expected results:
packages from kickstart file are embedded into the live image.

Additional info:
Comment 1 Jeremy Katz 2009-02-02 10:11:24 EST
Can you try with the livecd-tools-021 build for F10 that's in koji?
Comment 2 Alexander Todorov 2009-02-02 10:37:16 EST
The koji build doesn't have this traceback so we can say that it works for me. Still haven't fully tested if resulting ISO image is exactly what I need but that can go into another bug report if need to.
Comment 3 Jeremy Katz 2009-02-02 18:21:52 EST
It's queued up for -updates-testing at least now
Comment 4 Chris Shoemaker 2009-05-19 16:46:03 EDT
This must be resolved by now, yes?
Comment 5 Jeremy Katz 2009-07-21 14:31:19 EDT
Closing out bug that's been in MODIFIED for a while.

Note You need to log in before you can comment on or make changes to this bug.