This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 483272 - Opening a document in Openoffice crashes and restarts X server
Opening a document in Openoffice crashes and restarts X server
Status: CLOSED DUPLICATE of bug 469572
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 11:45 EST by Philippe Rigault
Modified: 2009-02-18 17:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 17:26:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf for HP DV2854ca (598 bytes, text/plain)
2009-01-30 12:13 EST, Philippe Rigault
no flags Details
My log after a crash on a Lenovo T61. (19.75 KB, text/plain)
2009-02-16 04:10 EST, Frank de Groodt
no flags Details

  None (edit)
Description Philippe Rigault 2009-01-30 11:45:04 EST
Description of problem:
Opening a document in OpenOffice.org sometimes results in restarting the X server, killing the user's session which is _very_annoying_.
I have had the problem happen at least 5 times in the last month.
This is definitely a bug in OpenOfice, but I also consider it a bug in X to be sensitive to crash/restart from a userland application (unless OpenOffice sends precisely the killing signal to X, which I cannot tell).

Version-Release number of selected component (if applicable):
openoffice.org-writer-3.0.0-9.10.fc10.x86_64   
xorg-x11-server-Xorg-1.5.3-6.fc10.x86_64

How reproducible: Happens every once in a while, so far happened about 5 times in the last month, always in Writer but this is the application I use most so it might not be specific to Writer. It happened with all the different ways of opening a document:
 - Upon starting OO-writer
 - Upon opening a new document with File->New
 - Upon opening a document with CTRL-O
It happened both with the first instance of OO (crash at first document opening), and after having several documents already opened.

Steps to Reproduce:
1. Start X session
2. <Do various tasks>
3. Open a document in OpenOffice (either start OO-writer or File->Open or through CTRL-O)
  
Actual results: User's session gets killed, X server restarts, frustrated user gets back to graphical login prompt (and starts yelling at stupid computer, or in this cas files a bug report).


Expected results: New document opened in OpenOffice.


Additional info:
Comment 1 Caolan McNamara 2009-01-30 11:55:40 EST
OOo has never once taken out an XServer for me in 10 years of development for me :-), so this is not something that I've seen much of. So I'm swung towards blaming X, and the specific driver that you have, whichever that is.

Best to attach the information mentioned at
https://fedoraproject.org/wiki/User:Mcepl/Bug_reporting_HOWTO#Xorg_.26_co._bugs
to this bug so as to get the X details
Comment 2 Philippe Rigault 2009-01-30 12:13:05 EST
Created attachment 330491 [details]
xorg.conf for HP DV2854ca
Comment 3 Philippe Rigault 2009-01-30 12:14:40 EST
Precisions:
 1. I am using KDE (this happened in 3.5, 4.0 and 4.1).
 2. This happened on different hardware and since a few Fedora versions:
	a- Sun Ultra 20 (Nvidia card), KDE 3.5 (Fedora 8)
	b- HP Pavilion A6652f (desktop), both with the native Intel 3100 driver and more recently with a Nvidia 9500GT card. Fedora 8, 9 and 10.
	c- HP Pavilion DV2654ca (laptop) with Intel 3100 driver. Fedora 10
I am attaching the latter xorg.conf (c) since this just happened to me this morning on that machine.
Comment 4 Caolan McNamara 2009-02-04 03:58:14 EST
After it crashes for you attach "X server log file (/var/log/Xorg.*.log)", that might include some info as to what made X crash/exit
Comment 5 Matěj Cepl 2009-02-05 04:57:36 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Please note, that we don't support nvidia binary-only driver, so any logs you provide should be created only using open source drivers (either -nv or -nouveau).

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 Frank de Groodt 2009-02-16 04:10:21 EST
Created attachment 332012 [details]
My log after a crash on a Lenovo T61.
Comment 7 Frank de Groodt 2009-02-16 04:16:23 EST
Errr sorry to get your hopes up... binary driver... :(
Comment 8 Matěj Cepl 2009-02-16 12:07:48 EST
Yup, you got it :( Standard information follows:

Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat mailing lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo
Comment 9 Philippe Rigault 2009-02-16 17:36:21 EST
You are very prompt to blame X in the first place, and then binary drivers.
I specifically indicated when I reported this bug that this happens with the Intel hardware and its open source driver. I don't think this is a problem of binary drivers. 

I will reopen the bug if I can attach some log on the Intel platform.
Comment 10 Matěj Cepl 2009-02-16 17:45:10 EST
I am sorry, I got caught by comment 7 -- I confused hijacker of this bug with you. Please, do attach these logs from your system.

Thanks and sorry again
Comment 11 Philippe Rigault 2009-02-16 21:06:18 EST
No problem captain, hijacking thwarted, resume course to bug-free land.
Comment 12 Matěj Cepl 2009-02-17 09:43:40 EST
(In reply to comment #11)
> No problem captain, hijacking thwarted, resume course to bug-free land.

Meaning?
Comment 13 Philippe Rigault 2009-02-17 10:08:33 EST
Meaning that I hope we'll solve this eventually (sorry, I thought I was being clear _and_ funny, neither was true). Might take a while though, because with a difficult-to-reproduce bug like this.
Comment 14 Matěj Cepl 2009-02-18 17:08:07 EST
Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e7a26]
1: /usr/bin/Xorg(xf86SigHandler+0x39) [0x47a679]
2: /lib64/libc.so.6 [0x3c05032f90]
3: /usr/bin/Xorg(XkbStringText+0x1c) [0x56711c]
4: /usr/bin/Xorg(XkbWriteXKBGeometry+0x15a) [0x55879a]
5: /usr/bin/Xorg(XkbWriteXKBKeymapForNames+0x5bb) [0x557d1b]
6: /usr/bin/Xorg(XkbDDXLoadKeymapByNames+0x18a) [0x561cba]
7: /usr/bin/Xorg(ProcXkbGetKbdByName+0x3ab) [0x53fb2b]
8: /usr/bin/Xorg(Dispatch+0x364) [0x4468d4]
9: /usr/bin/Xorg(main+0x45d) [0x42cd1d]
10: /lib64/libc.so.6(__libc_start_main+0xe6) [0x3c0501e576]
11: /usr/bin/Xorg [0x42c0f9]

Fatal server error:
Caught signal 11.  Server aborting
Comment 15 Matěj Cepl 2009-02-18 17:26:56 EST

*** This bug has been marked as a duplicate of bug 469572 ***

Note You need to log in before you can comment on or make changes to this bug.