Bug 483288 - Network Disabled after Suspend
Network Disabled after Suspend
Status: CLOSED DUPLICATE of bug 477964
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 487062 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 12:57 EST by Daryll
Modified: 2009-02-27 08:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 11:49:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daryll 2009-01-30 12:57:07 EST
My laptop can seems to suspend and restore correctly, but in about 1/3 of the cases after the resume NetworkManager will indicate that networking is disabled. If I then do a 'server NetworkManager restart' NetworkManager recognizes that the networking is enabled and finds the wireless correctly. It seems like a race condition where during a resume NetworkManager will sometimes check too early and find that networking has not yet been enabled.

NetworkManager-0.7.0-1.git20090102.fc10.i386
Linux ninja 2.6.27.9-159.fc10.i686 #1 SMP Tue Dec 16 15:12:04 EST 2008 i686 i686 i386 GNU/Linux
Comment 1 Chris Bredesen 2009-01-31 17:19:05 EST
I'm experiencing this as well on my Dell D620.

0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
NetworkManager-0.7.0-1.git20090102.fc10.i386
Linux interlagos 2.6.27.12-170.2.5.fc10.i686 #1 SMP Wed Jan 21 02:09:37 EST 2009 i686 i686 i386 GNU/Linux

When I re-enable networking, it usually takes several seconds (up to a minute) to re-detect my WiFi access point.  But the main issue is that networking is disabled.  I'm happy to provide any extra logging you need to diagnose this.
Comment 2 Dan Williams 2009-02-03 11:49:45 EST

*** This bug has been marked as a duplicate of bug 477964 ***
Comment 3 cblaauw 2009-02-27 08:44:35 EST
*** Bug 487062 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.