Bug 483327 - baekmuk-ttf-fonts : Unowned directories
baekmuk-ttf-fonts : Unowned directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: baekmuk-ttf-fonts (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 15:36 EST by Michael Schwendt
Modified: 2009-05-05 01:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 01:30:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-01-30 15:36:55 EST
One or more directories are not included within this
package and/or its sub-packages:

=> baekmuk-ttf-fonts-2.2-17.fc11.src.rpm
=> baekmuk-ttf-batang-fonts-2.2-17.fc11.noarch (rawhide-development-i386)
/usr/share/fonts/baekmuk-ttf

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories

The script to find unowned directories is not complete yet, but
still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
$ ./dircheck-remote.py -r rawhide -n ^baekmuk-ttf
Comment 1 Michael Schwendt 2009-01-30 15:38:03 EST
=> baekmuk-ttf-fonts-2.2-17.fc11.src.rpm
=> baekmuk-ttf-batang-fonts-2.2-17.fc11.noarch (rawhide-development-i386)
/usr/share/fonts/baekmuk-ttf

=> baekmuk-ttf-fonts-2.2-17.fc11.src.rpm
=> baekmuk-ttf-dotum-fonts-2.2-17.fc11.noarch (rawhide-development-i386)
/usr/share/fonts/baekmuk-ttf

=> baekmuk-ttf-fonts-2.2-17.fc11.src.rpm
=> baekmuk-ttf-fonts-common-2.2-17.fc11.noarch (rawhide-development-i386)
/usr/share/ghostscript
    provided by: ghostscript-8.63-4.fc10.i386
/usr/share/fonts/baekmuk-ttf

=> baekmuk-ttf-fonts-2.2-17.fc11.src.rpm
=> baekmuk-ttf-gulim-fonts-2.2-17.fc11.noarch (rawhide-development-i386)
/usr/share/fonts/baekmuk-ttf

=> baekmuk-ttf-fonts-2.2-17.fc11.src.rpm
=> baekmuk-ttf-hline-fonts-2.2-17.fc11.noarch (rawhide-development-i386)
/usr/share/fonts/baekmuk-ttf
Comment 2 Nicolas Mailhot 2009-01-30 16:30:57 EST
1. The -common subpackage is missing the %{_fontdir} line of the template
2. the gs stuff should probably be moved in a subpackage that depends on ghostscript
Comment 3 Nicolas Mailhot 2009-01-30 16:32:10 EST
(more accurately the %dir %{_fontdir} line)
Comment 4 Caius Chance 2009-02-02 21:13:28 EST
1 & 2 have been resolved:

http://koji.fedoraproject.org/koji/buildinfo?buildID=81270
Comment 5 Michael Schwendt 2009-04-01 06:32:14 EDT
Should all these packages depend on the "fontpackages-filesystem" package? That one provides four directories needed here.
Comment 6 Nicolas Mailhot 2009-04-01 06:48:38 EDT
If the official template is respected the font subpackages depend on the common subpackage and the common subpackage depends on fontpackages-filesystem
Comment 7 Michael Schwendt 2009-04-01 06:56:53 EDT
Then there's a missing dep in "baekmuk-ttf-fonts", because the following unowned directories are found:

$ ./dircheck-remote.py -r rawhide -n ^baekmuk
[...]
=> baekmuk-ttf-fonts-2.2-20.fc11.src.rpm
=> baekmuk-ttf-batang-fonts-2.2-20.fc11.noarch (rawhide)
/etc/fonts
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/etc/fonts/conf.d
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/usr/share/fontconfig
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/usr/share/fontconfig/conf.avail
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch

=> baekmuk-ttf-fonts-2.2-20.fc11.src.rpm
=> baekmuk-ttf-dotum-fonts-2.2-20.fc11.noarch (rawhide)
/etc/fonts
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/etc/fonts/conf.d
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/usr/share/fontconfig
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/usr/share/fontconfig/conf.avail
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch

=> baekmuk-ttf-fonts-2.2-20.fc11.src.rpm
=> baekmuk-ttf-gulim-fonts-2.2-20.fc11.noarch (rawhide)
/etc/fonts
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/etc/fonts/conf.d
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/usr/share/fontconfig
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/usr/share/fontconfig/conf.avail
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch

=> baekmuk-ttf-fonts-2.2-20.fc11.src.rpm
=> baekmuk-ttf-hline-fonts-2.2-20.fc11.noarch (rawhide)
/etc/fonts
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/etc/fonts/conf.d
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/usr/share/fontconfig
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
/usr/share/fontconfig/conf.avail
    provided by: fontpackages-filesystem-1.20-2.fc11.noarch
Comment 8 Caius Chance 2009-05-05 01:30:24 EDT
done

http://koji.fedoraproject.org/koji/buildinfo?buildID=96998

Note You need to log in before you can comment on or make changes to this bug.