Bug 483335 - cwirc : Unowned directories
cwirc : Unowned directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cwirc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Randall "Randy" Berry
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 15:43 EST by Michael Schwendt
Modified: 2009-02-01 08:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-01 08:58:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cvs devel diff (534 bytes, patch)
2009-01-31 04:53 EST, Michael Schwendt
no flags Details | Diff

  None (edit)
Description Michael Schwendt 2009-01-30 15:43:10 EST
One or more directories are not included within this
package and/or its sub-packages:

=> cwirc-2.0.0-4.fc11.src.rpm
=> cwirc-2.0.0-4.fc11.i386 (rawhide-development-i386)
/usr/lib/cwirc

[...]

Further information:

https://fedoraproject.org/wiki/Packaging/ReviewGuidelines

MUST: A package must own all directories that it creates. If it does not
create a directory that it uses, then it should require a package which
does create that directory.

https://fedoraproject.org/wiki/Packaging/Guidelines#FileAndDirectoryOwnership
https://fedoraproject.org/wiki/Packaging/UnownedDirectories

The script to find unowned directories is not complete yet, but
still quite usable: http://mschwendt.fedorapeople.org/dircheck-remote.py
$ ./dircheck-remote.py -r rawhide -n cwirc
Comment 1 Randall "Randy" Berry 2009-01-30 19:30:39 EST
Thank you,
working to correct
Comment 2 Michael Schwendt 2009-01-31 04:53:39 EST
Created attachment 330522 [details]
cvs devel diff

The linked Wiki pages explain it. There are several ways how to fix it. Which way to use in your spec file depends on what you like most. Sometimes readability is increased, sometimes verbosity.

No need to submit updates for F10/F9. The issue is not worse enough.

Note You need to log in before you can comment on or make changes to this bug.