Bug 483368 - amsn won't start - loading TkCximage failed.
amsn won't start - loading TkCximage failed.
Product: Fedora
Classification: Fedora
Component: amsn (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Sander Hoentjen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-01-30 19:42 EST by Austin
Modified: 2009-04-22 04:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-22 04:51:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screen shot of the AMSN failure message. (11.73 KB, image/png)
2009-01-30 19:42 EST, Austin
no flags Details

  None (edit)
Description Austin 2009-01-30 19:42:41 EST
Created attachment 330515 [details]
Screen shot of the AMSN failure message.

Description of problem:
When trying to run amsn on Fedora 10 (i686), it just pops up a dialog that says :

"Loading TkCximage failed. This module is needed to run aMSN. Please compile aMSN first, instructions on how to compile are located in the file INSTALL."

Version-Release number of selected component (if applicable):
amsn.i386 0:0.97.2-1.fc10

How reproducible:
Every time.

Steps to Reproduce:
1. Run "yum install amsn"
2. Locate AMSN in the menus (or run from a terminal)
3. Observe failure.
Actual results:
Attached error message.

Expected results:
For it to work.

Additional info:
Comment 1 David Nielsen 2009-02-17 10:45:19 EST
I can confirm this on F11
Comment 2 Sander Hoentjen 2009-02-17 15:27:35 EST
Updates built for F-10 and rawhide. The problem was caused by a tcl/tk update.
For F-10 you can download the updated rpm's from here or wait till they hit the updates repo.
Comment 3 Austin 2009-02-24 05:53:28 EST
Not quite fixed.

I ran "rpm -Uvh  http://kojipkgs.fedoraproject.org/packages/amsn/0.97.2/2.fc10/i386/amsn-0.97.2-2.fc10.i386.rpm", and I still get this error message.
Comment 4 David Nielsen 2009-02-24 07:48:28 EST
you need -3 which actually fixes this, which unfortunately does not seem to have been built for F9+10.. Sander?

Comment 5 Sander Hoentjen 2009-02-24 12:42:16 EST
F10 .2 is the same as F11 .3, so in theory it should work. I will install F10 to test. Will update when I know more.
Comment 6 Sander Hoentjen 2009-02-24 14:03:01 EST
Hmm, can't seem to reproduce.
What does `rpm -q tcl` tell you?
Comment 7 Austin 2009-02-25 06:48:46 EST
I assume this is directed at me?

$ rpm -qa tcl*

$ rpm -qa amsn*
Comment 8 Sander Hoentjen 2009-02-25 08:24:24 EST
Austin, yes it was directed to you, sorry.
Can you also give the output of:
rpm -Va amsn\* tcl\*

and als try:
$ wish
% package require TkCximage
% image create photo -format cximage

Thanks in advance!
Comment 9 Austin 2009-02-25 16:23:42 EST
The rpm -V commands return nothing.

$ wish
% package require TkCximage
% image create photo -format cximage

... which displayed an empty wish window and nothing more.
Comment 10 Sander Hoentjen 2009-02-26 01:53:14 EST
Hi, please edit the file /usr/share/amsn/picture.tcl
and change so it reads (starting line 23):
                        # We try to create an image of format cximage, if TkCximage was loaded, then it will work, if not, it will fail.
                        # This is because the previous 'load' could load the .so even if it was compiled for another version of Tcl/Tk
                        if { [catch {image create photo -format cximage -file [::skin::GetSkinFile pixmaps null] } err ] == 0 } {
                                puts success
                                set ::tkcximageloaded 1
                                return 1
                        } else {
                                puts fail
                                puts $err

After that run amsn from command line and see what it displays. I hope this will give the info we need.
Comment 11 Austin 2009-02-26 05:06:50 EST
Modified as requested:

$ amsn
version conflict for package "Tcl": have 8.5.3, need exactly 8.4

Should be >= 8.4 instead of = 8.4 ?
Comment 12 Sander Hoentjen 2009-02-26 13:41:04 EST
hmm very change, can you do:
updatedb && locate TkCximage
you should only see something like:

also check the output of:
$ wish
% set auto_path

If there is a different dir TkCxImage that is in auto_path that would cause the problem.
Comment 13 Austin 2009-02-28 06:33:23 EST
$ updatedb && locate TkCximage
$ wish
% set auto_path
/usr/share/tcl8.5 /usr/lib/tcl8.5 /usr/lib/tk8.5 /usr/share/tk8.5 /usr/share/tk8.5/ttk
Comment 14 Sander Hoentjen 2009-02-28 06:41:41 EST
ah, now we are getting somewhere..

please try
rpm -qf /usr/share/amsn/utils/TkCximage

if it says not owned by any package please remove that dir (or move it to somewhere out of the way atleast).
Comment 15 Austin 2009-03-26 06:56:50 EDT
Sorry for the delay in responding.

$ rpm -qf /usr/share/amsn/utils/TkCximage
file /usr/share/amsn/utils/TkCximage is not owned by any package
$ cd /usr/share/amsn/utils/
$ sudo mv TkCximage TkCximage.old
$ amsn
couldn't load file "utils/TkCximage/TkCximage.so": utils/TkCximage/TkCximage.so: cannot open shared object file: No such file or directory

What do I try next?
Comment 16 Austin 2009-03-26 08:15:02 EDT
OK, looking a little further, I went back to /usr/share/amsn, and ran:
$ rpm -qf *

LOTS of directories were not owned by any package, so I simple erased amsn
$ yum erase amsn

$ sudo rm -rf /usr/share/amsn

Lastly, I re-installed with:
$ sudo yum -y install amsn

Voila! It worked.

Goodness knows where those other directories came from.

Note You need to log in before you can comment on or make changes to this bug.