Bug 483397 - gnome-sound-properties (system->preferences->hardware->sound) failure to start
gnome-sound-properties (system->preferences->hardware->sound) failure to start
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-audio (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-31 11:48 EST by John Murphy
Modified: 2009-05-14 09:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 09:31:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Murphy 2009-01-31 11:48:38 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5

On the top panel menu, selecting "System->Preferences->Hardware->Sound"...
Entry "Starting Sound" shows for a few seconds on bottom panel task bar, then goes away. No GUI ever starts.


Reproducible: Always

Steps to Reproduce:
On the top panel menu, select "System->Preferences->Hardware->Sound"
Actual Results:  
Entry "Starting Sound" shows for a few seconds on bottom panel task bar, then goes away. No GUI ever starts.

Expected Results:  
GUI should come up for entering system sound properties.

hardware is a HP laptop model dv2120us

dbus-1:1.2.4-2.fc10(x86_64)
hal-0.5.12-14.20081027git.fc10(x86_64)
kernel-2.6.27.12-170.2.5.fc10(x86_64)

(not sure what version info re dependencies you need)

everything sound-related was installed as part of the distribution

linux distribution Fedora10 x86_64

have pulse audio but no idea actually what audio setup I want, just more or less picked everything that looked like it might be desired from the distro install menu (from the full distro DVD)
Comment 1 John Murphy 2009-02-02 12:26:36 EST
.xsession-errors

Error re-scanning registry , child terminated by signal
Run 'gnome-sound-properties --help' to see a full list of available command line options.

that is the only debug info I see related at the moment, unless you have any pointer to what is going on. btw various gnome packages updated this morning so may not be the same as what is in the original report but the symptoms are unchanged as of new update to gnome 2.24.3
Comment 2 Bastien Nocera 2009-04-23 11:52:02 EDT
That means that rebuilding the registry of GStreamer plugins failed for some reason or another.

Try getting a backtrace of "gst-inspect-0.10 --gst-disable-registry-fork".
Comment 3 John Murphy 2009-05-14 09:31:21 EDT
Unfortunately over one of the many updates since this bug appeared it seems to have gone away for reasons unknown, and I now get the GUI to come up.

Good news for me, maybe bad news for testing, but maybe it means the problem was taken care of in another bug fix.

Anyhow, I am closing this bug, hope that is okay.

Note You need to log in before you can comment on or make changes to this bug.