Bug 483404 - system-config-firewall freezes after opening
system-config-firewall freezes after opening
Status: CLOSED DUPLICATE of bug 486605
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-31 16:02 EST by Fabrício Godoy
Modified: 2009-03-16 12:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 12:58:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrício Godoy 2009-01-31 16:02:10 EST
Description of problem:
system-config-firewall freezes after opening and uses ~99% CPU.

Version-Release number of selected component (if applicable):
system-config-firewall-1.2.13-2.fc10.noarch

How reproducible:
Just open system-config-firewall

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Freezes and uses ~99% CPU.

Expected results:


Additional info:
[root@localhost ~]# gdb python
GNU gdb Fedora (6.8-29.fc10)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
(gdb) run /usr/share/system-config-firewall/system-config-firewall.py
Starting program: /usr/bin/python /usr/share/system-config-firewall/system-config-firewall.py
[Thread debugging using libthread_db enabled]
[New Thread 0x7ffff7fcb6f0 (LWP 7406)]
Detaching after fork from child process 7415.
Detaching after fork from child process 7419.
[New Thread 0x7fffebfa7950 (LWP 7423)]
[New Thread 0x7fffeb5a6950 (LWP 7424)]
[Thread 0x7fffeb5a6950 (LWP 7424) exited]
[Thread 0x7fffebfa7950 (LWP 7423) exited]
^C
Program received signal SIGINT, Interrupt.
0x0000003b1cbef35a in gtk_tree_model_iter_next ()
   from /usr/lib64/libgtk-x11-2.0.so.0
Missing separate debuginfos, use: debuginfo-install GConf2-2.24.0-1.fc10.x86_64 ORBit2-2.14.16-1.fc10.x86_64 at-spi-1.24.0-5.fc10.x86_64 atk-1.24.0-1.fc10.x86_64 bug-buddy-2.24.2-1.fc10.x86_64 cairo-1.8.0-1.fc10.x86_64 dbus-glib-0.76-3.fc10.x86_64 dbus-libs-1.2.4-2.fc10.x86_64 e2fsprogs-libs-1.41.3-2.fc10.x86_64 elfutils-libelf-0.137-3.fc10.x86_64 fontconfig-2.6.0-3.fc10.x86_64 freetype-2.3.7-2.fc10.x86_64 gamin-0.1.9-6.fc10.x86_64 glib2-2.18.3-2.fc10.x86_64 gtk2-2.14.5-3.fc10.x86_64 gtk2-engines-2.16.1-1.fc10.x86_64 gvfs-1.0.3-4.fc10.x86_64 keyutils-libs-1.2-3.fc9.x86_64 krb5-libs-1.6.3-16.fc10.x86_64 libICE-1.0.4-4.fc10.x86_64 libSM-1.1.0-2.fc10.x86_64 libX11-1.1.4-6.fc10.x86_64 libXau-1.0.4-1.fc10.x86_64 libXcomposite-0.4.0-5.fc10.x86_64 libXcursor-1.1.9-3.fc10.x86_64 libXdamage-1.1.1-4.fc9.x86_64 libXdmcp-1.0.2-6.fc10.x86_64 libXext-1.0.4-1.fc9.x86_64 libXfixes-4.0.3-4.fc10.x86_64 libXi-1.1.3-4.fc9.x86_64 libXinerama-1.0.3-2.fc10.x86_64 libXrandr-1.2.3-1.fc10.x86_64 libXrender-0.9.4-3.fc9.x86_64 libXtst-1.0.3-3.fc9.x86_64 libbeagle-0.3.5-1.fc9.x86_64 libbonobo-2.24.0-2.fc10.x86_64 libcanberra-0.10-3.fc10.x86_64 libcanberra-gtk2-0.10-3.fc10.x86_64 libcap-2.10-2.fc10.x86_64 libgcc-4.3.2-7.x86_64 libglade2-2.6.3-2.fc10.x86_64 libogg-1.1.3-9.fc9.x86_64 libpng-1.2.33-1.fc10.x86_64 libselinux-2.0.73-1.fc10.x86_64 libstdc++-4.3.2-7.x86_64 libtdb-1.1.1-25.fc10.x86_64 libtool-ltdl-1.5.26-4.fc10.x86_64 libvorbis-1.2.0-5.fc10.x86_64 libxcb-1.1.91-5.fc10.x86_64 libxml2-2.7.2-2.fc10.x86_64 pango-1.22.3-1.fc10.x86_64 pixman-0.12.0-2.fc10.x86_64 pycairo-1.4.12-4.fc10.x86_64 pygobject2-2.15.4-3.fc10.x86_64 pygtk2-2.13.0-2.fc10.x86_64 pygtk2-libglade-2.13.0-2.fc10.x86_64 rhpl-0.218-1.x86_64
(gdb) quit
The program is running.  Exit anyway? (y or n) y
[root@localhost ~]#
Comment 1 Francesco Tapparo 2009-02-28 03:17:31 EST
I have a similar problem but I've noticed a thing that you could find useful: my system is a fresh install (with updates applied), with an old /home partition (I've reinstalled the system but kept the original /home); still system-config-firewall presents this problem. I noticed that if I launch s-c-f from one user it blocks just after started but if I launch it from the other (rarely used) user, it works perfectly.

I hope this helps
Francesco
Comment 2 Fabrício Godoy 2009-03-01 17:37:49 EST
My /home partition exists since fc7...
But the user thar runs system-config-firewall is root, I can't run with another user.
Comment 3 Thomas Woerner 2009-03-02 03:51:38 EST
Do you have assistive technologies turned on?
Comment 4 Francesco Tapparo 2009-03-02 04:37:23 EST
to Thomas Woerner:

yes I have: after reading your answer I tried to disable them and s-c-f started working!
I've turned them on again and s-f-c does not work anymore so it seems that this is the root of the problem.

Francesco
Comment 5 Fabrício Godoy 2009-03-02 19:06:39 EST
Yes, system-config-firewall freeze when assistive technologies is turned on.
I turned assistive technologies off and system-config-firewall worked well.
Comment 6 Thomas Woerner 2009-03-16 12:58:55 EDT

*** This bug has been marked as a duplicate of bug 486605 ***

Note You need to log in before you can comment on or make changes to this bug.