Bug 483407 - Advent 4213 - No wifi
Advent 4213 - No wifi
Status: CLOSED DUPLICATE of bug 459439
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraMini/Mobility
  Show dependency treegraph
 
Reported: 2009-01-31 16:52 EST by Luke Sheldrick
Modified: 2009-02-03 16:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 16:22:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vnn (8.72 KB, text/plain)
2009-01-31 16:52 EST, Luke Sheldrick
no flags Details

  None (edit)
Description Luke Sheldrick 2009-01-31 16:52:28 EST
Created attachment 330532 [details]
lspci -vnn

Description of problem:

No wifi is detected in Fedora 10 on the advent 4213 notebook.


Version-Release number of selected component (if applicable):
Latest from the repos. 

[root@smallfry ~]# rpm -qa | grep kernel
kerneloops-0.12-1.fc10.i386
kernel-2.6.27.5-117.fc10.i686
kernel-firmware-2.6.27.12-170.2.5.fc10.noarch
kernel-2.6.27.12-170.2.5.fc10.i686
kernel-headers-2.6.27.12-170.2.5.fc10.i386
[root@smallfry ~]# rpm -qa | grep Network
NetworkManager-openvpn-0.7.0-18.svn11.fc10.i386
NetworkManager-0.7.0-1.git20090102.fc10.i386
NetworkManager-vpnc-0.7.0-1.svn13.fc10.i386
NetworkManager-gnome-0.7.0-1.git20090102.fc10.i386
NetworkManager-glib-0.7.0-1.git20090102.fc10.i386



How reproducible:


Steps to Reproduce:
1. Get a 4213 
2. Install fc10
3. Update via yum
  
Actual results:
No wifi is picked up by NetworkManager

Expected results:
That wifi stations are shown in NetworkManager

Additional info:
Comment 1 Dan Williams 2009-02-03 11:48:08 EST
Can you do the following, all as root?

service NetworkManager stop
killall -TERM wpa_supplicant
iwlist wlan0 scan

Does the last command show any output?
Comment 2 Luke Sheldrick 2009-02-03 13:24:18 EST
[luke@smallfry ~]$ sudo su -
[root@smallfry ~]# service NetworkManager stop
Stopping NetworkManager daemon:                            [  OK  ]
[root@smallfry ~]# killall -TERM wpa_supplicant 
[root@smallfry ~]# iwlist wlan0 scan
wlan0     Interface doesn't support scanning.
Comment 3 Dan Williams 2009-02-03 13:44:24 EST
Ok, with NetworkManager and the supplicant *still* stopped, try (as root):

ifconfig wlan0 up
iwlist wlan0 scan


I forgot that for most devices, they need to be "up" first.
Comment 4 Luke Sheldrick 2009-02-03 14:00:44 EST
wlan0: unknown interface: No such device
Comment 5 Dan Williams 2009-02-03 14:16:05 EST
What wifi devices does "iwconfig" report?
Comment 6 Luke Sheldrick 2009-02-03 14:24:06 EST
Doesn't pick any up;

lo              no wireless extensions.

eth0            no wireless extensions.

pan0            no wireless extensions.
Comment 7 Dan Williams 2009-02-03 14:31:33 EST
Ah, ok, misunderstood.  The problem is that there is (as yet) no kernel driver for your hardware, which is a Realtek 8187SE 802.11b/g part.
Comment 8 Peter Robinson 2009-02-03 15:21:17 EST
Is there any plans to enable any of the wireless drivers in the staging part of the kernel tree? This would enable testing of both these drivers and the other fun driver in a lot of netbooks - the Ralink RT2860

http://lwn.net/Articles/313521/
Comment 9 Dan Williams 2009-02-03 15:50:31 EST
No.  These drivers are not of suitable quality, and kernel wireless people object to their inclusion in staging in the first place, since (at least in the case of ralink) the driver will *never* be officially accepted until it's completely rewritten anyway, since it doesn't use the kernel's standard 802.11 stack.  Other staging drivers like at76_usb *do* use the standard 802.11 stack, so they are much more likely to be enabled.

Staging drivers are not of acceptable quality to be included in the mainstream Linux kernel, and thus we shouldn't be turning them on in Fedora at a whim either.  Any panics or problems with staging or otherwise out-of-kernel drivers like ndiswrapper, nvidia, ati, etc are likely to be ignored, because they have not passed the kernel's quality acceptance bar and are not mainstream.
Comment 10 John W. Linville 2009-02-03 16:22:29 EST

*** This bug has been marked as a duplicate of bug 459439 ***

Note You need to log in before you can comment on or make changes to this bug.