Bug 483411 - Expat not enabled, Ekiga presence does not work without it
Expat not enabled, Ekiga presence does not work without it
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ptlib (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-31 17:13 EST by Michael Cronenworth
Modified: 2009-02-18 05:18 EST (History)
2 users (show)

See Also:
Fixed In Version: ekiga-3.0.2-2.fc10, opal-3.4.4-4.fc10, ptlib-2.4.4-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 05:18:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 569837 None None None Never

  None (edit)
Description Michael Cronenworth 2009-01-31 17:13:51 EST
Description of problem: The expat feature of ptlib must be explicitly enabled in the configure call. Please add --enable-expat to the configure call in the ptlib.spec file.


Version-Release number of selected component (if applicable): ptlib-2.4.4-1.1.fc10


How reproducible: Always


Additional info: This will require a rebuild of opal as well.

Presence (offline/online) support will work when these two packages are rebuilt.
Comment 1 Peter Robinson 2009-02-01 03:13:17 EST
I'll do some testing for this later this week. The configure options between the 3 packages are very problematic.
Comment 2 Michael Cronenworth 2009-02-01 13:48:09 EST
Thanks.

In my testing, I had to only add --enable-expat on ptlibs, rebuild ptlibs and opal, and presence worked. Ekiga did not need to be rebuilt. This is shown in my bug report from Gnome that I linked, too.

Opal did not detect XML support at compile time from ptlibs and therefore didn't read the XML from presence messages.
Comment 3 Peter Robinson 2009-02-01 14:00:19 EST
Hmm. Was this working in 3.0.1?
Comment 4 Michael Cronenworth 2009-02-01 14:04:04 EST
No. Presence support never worked with 3.x.x in Fedora. I just got around to filing a bug with Gnome this week. The Ekiga folks said that they had a unrelated bug with presence but they fixed it in 3.0.2 and OPAL 3.4.4 and said it was impossible for me to have it not work now. After investigating I found it was ptlibs built without the proper configure line.
Comment 5 Peter Robinson 2009-02-01 14:11:40 EST
so did it work with standard ekiga 2.x in Fedora previously?
Comment 6 Michael Cronenworth 2009-02-01 14:42:27 EST
No, because presence support was added in 3.x.
Comment 7 Michael Cronenworth 2009-02-01 14:45:38 EST
You might want to look at the comment just made in the Gnome bug. Debian builds without "--enable-expat" explicitly set and expat is enabled. I did not find anything in your ptlib.spec or ptlib package that disabled expat on purpose, so maybe you need to look it over again to make sure.
Comment 8 Peter Robinson 2009-02-01 14:54:21 EST
That was the way I read the output of ./configure --help but for some reason it doesn't detect it even though it should, adding the enable fixes it without adding any extra build deps. I'm going through my tests for it now but it will probably take nearly a week to get all the builds done for mainline Fedora. The ptlib/opal configure scripts have a horrible tendency to break random things even between minor releases. It took me 8-9 builds to get the beta to build in rawhide even though it built fine in my local testing. Grr
Comment 9 Peter Robinson 2009-02-01 17:13:18 EST
The cause of the issue has been identified and I've reported an upstream bug and had a conversation with the ekiga maintainer. I'm updating the ptlib for F-10 but it will take a little time to push a complete update as each ptlib/opal build will need to be explicitly tagged by rel-eng to build the dependant packages.
Comment 10 Fedora Update System 2009-02-04 21:22:13 EST
ekiga-3.0.2-2.fc10, opal-3.4.4-4.fc10, ptlib-2.4.4-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ekiga opal ptlib'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1363
Comment 11 Peter Robinson 2009-02-05 02:52:51 EST
Michael, can you test this for me and confirm it fixes presence for you?
Comment 12 Michael Cronenworth 2009-02-05 12:14:17 EST
Yes, I'm waiting on them to show up in updates-testing so I can download them and apply karma. They weren't there last night. I'll try again tonight.
Comment 13 Michael Cronenworth 2009-02-06 20:53:49 EST
Success. I've added karma to match. Thanks, Peter.
Comment 14 Peter Robinson 2009-02-18 05:18:56 EST
Fixed in F-10 stable. Versions ekiga-3.0.2-2.fc10, opal-3.4.4-4.fc10, ptlib-2.4.4-2.fc10

Note You need to log in before you can comment on or make changes to this bug.