Bug 483419 - bluetooth-wizard fails to connect properly to Bluetooth mouse
bluetooth-wizard fails to connect properly to Bluetooth mouse
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: bluez-gnome (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-31 21:16 EST by Adam Williamson
Modified: 2014-06-16 18:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:45:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2009-01-31 21:16:51 EST
Description of problem:

I just bought a Bluetooth mouse (Microsoft Bluetooth Notebook Mouse 5000). Brought it home and tried to set it up the Official Way - via bluetooth-wizard, launched from the panel Bluetooth applet. It discovered it fine, and when I selected it from the list, it went on to the next screen and claimed to have completed successfully. However, the mouse wasn't working at all.

Looking in /var/log/messages, I saw:

bluetoothd[2065]: connect(): Connection refused (111)

I tried several times to delete the pairing and re-pair the device; every time, that message would show up in /var/log/messages, and the mouse wouldn't work.

'hcitool con' and 'hidd --show' both reported no active connections.

After a while I looked for a workaround, and found this old guide:

http://www.boplicity.net/confluence/display/Linux/Bluetooth+Mouse+with+Fedora

following that works perfectly. I just ran hidd --server --search as root, and it worked - it completed successfully and the mouse began to work immediately.


Version-Release number of selected component (if applicable): 1.8-11.fc10


How reproducible: Every time


Steps to Reproduce:
1. Set mouse to pairing mode
2. Attempt to pair mouse
3. Try to use mouse, and examine /var/log/messages
  
Actual results: Mouse no worky


Expected results: Mouse worky!


Additional info:
Comment 1 Bastien Nocera 2009-03-04 19:59:21 EST
This should be fixed by setting the mouse to be trusted in the preferences. Select the mouse in the paired devices, and select "trust".

In recent versions, bluez-gnome's wizard will do it automatically.
Comment 2 Wil Cooley 2009-05-23 19:11:45 EDT
I am experiencing the same issue with the same brand and model of mouse as the reporter. I worked around similarly by running as root 'hidd --connect XX'.

My bluetooth-properties showed the device as trusted and I also tried several cycles of 'Distrust/Trust', to no avail.
Comment 3 Adam Williamson 2009-05-25 15:32:51 EDT
Yeah, I tried setting it to be trusted as well (sorry I didn't notice your followup earlier, Bastien).
Comment 4 Adam Williamson 2009-05-25 15:33:56 EDT
I'll test this with F11 at some point when I update my laptop. But, uh, do either of you know how to clear whatever voodoo makes it work after doing hidd, so I know whether or not GNOME is handling it correctly? Right now, the mouse just works, all the time, through mouse power cycles, laptop power cycles, suspend, resume, anything - this is obviously good for me, but it's tricky for testing purposes :)
Comment 5 Bastien Nocera 2009-05-26 06:10:14 EDT
Just stop the running hidd.

If setting the device as trusted doesn't work, then you can try connecting to the mouse using the mouse menu item in the applet.
Comment 6 Adam Williamson 2009-05-27 00:38:32 EDT
That's the problem - there isn't a running hidd. Hence my description of it as 'voodoo'. I can't actually figure out what the hell bit of running code makes the mouse work, hence I can't stop it..."ps aux | grep hid" just returns nothing. I'll try and find a bit of time to dump an entire running process list out to a text file and go through it with a fine tooth comb at some point, but this isn't at the top of my priority list right now :\ leaving it in needinfo is fine, i'll set it back to that after posting this comment.
Comment 7 Bug Zapper 2009-11-18 04:47:33 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-12-18 02:45:44 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.