Bug 483422 - Broken strinparam handling
Summary: Broken strinparam handling
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xmlto
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-02-01 04:14 UTC by Dan Nicholson
Modified: 2009-02-05 02:09 UTC (History)
1 user (show)

Fixed In Version:
Clone Of:
Environment:
Last Closed: 2009-02-05 02:09:11 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Fix --stringparam handling (1.01 KB, patch)
2009-02-01 04:14 UTC, Dan Nicholson
no flags Details | Diff

Description Dan Nicholson 2009-02-01 04:14:42 UTC
Created attachment 330535 [details]
Fix --stringparam handling

stringparam handling is broken in xmlto.

$ xmlto --stringparam foo='bar baz' html doc/xmlto.xml 
warning: failed to load external entity "XSLTPARAMS"
cannot parse XSLTPARAMS
Variable $SGML_CATALOG_FILES not set
warning: failed to load external entity "XSLTPARAMS"
cannot parse XSLTPARAMS

Attached is a patch that fixes this.

Also, what's up with xmlto on fedorahosted? Only the tarball is stored in svn? Where's the source repo?

Comment 1 Ondrej Vasik 2009-02-02 08:29:03 UTC
Thanks for report. stringparams issue (and few other things) is already fixed in RAWHIDE, will do an xmlto update for lower Fedora's this week. I do plan to improve fedorahosted xmlto pages for xmlto 0.0.22 (hopefully this month, most of the patches ready, just have to merge them and add few things). I know about xmlto fedorahosted svn issue, I'll fix it as well...

Comment 2 Fedora Update System 2009-02-05 02:09:08 UTC
xmlto-0.0.20-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.