Bug 483435 - Multimedia keys crash the X server
Multimedia keys crash the X server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 05:07 EST by Jan Martinek
Modified: 2018-04-11 03:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-10 19:56:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (160.65 KB, text/plain)
2009-02-01 05:07 EST, Jan Martinek
no flags Details
Xorg log with the backtrace (66.15 KB, text/plain)
2009-02-02 15:40 EST, Jan Martinek
no flags Details

  None (edit)
Description Jan Martinek 2009-02-01 05:07:17 EST
Created attachment 330541 [details]
Xorg log

Description of problem:
I have USB keyboard Genius SLIMSTAR with 12 multimedia keys. Pressing any of these keys results in X server crash.

Version-Release number of selected component (if applicable):
kernel-2.6.28-0.113.rc7.git5.fc11.x86_64
xorg-x11-server-Xorg-1.5.99.901-5.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. start X
2. press any multimedia key (Volume UP/Down, pause, www, calculator, whatever)
3. X server crashes and gdm appears again.
  
Expected results:
I remember that some time ago these keys worked and I could see their code using xev. It is not possible now due to the crash.

Additional info:
I have RS690 chipset and I am using xorg-x11-drv-ati. But, I also tried to uninstall the package xorg-x11-drv-ati. After reboot, the X server used VESA. It did not help, so the bug was still present.
Comment 1 Jan Martinek 2009-02-01 05:13:31 EST
Same results with kernel-2.6.29-0.66.rc3.fc11.x86_64.
Comment 2 Matěj Cepl 2009-02-02 11:33:56 EST
Weird, no backtrace in the log. Could we get /var/log/messages from the moment when Xorg crashed as well? Is this reproducible or just happened once?
Comment 3 Jan Martinek 2009-02-02 15:39:16 EST
Ooops, you are right. By mistake I attached a different log, sorry. The bug is reproducible. Here is the log with the backtrace.
Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4e97d6]
1: /usr/bin/X(xf86SigHandler+0x39) [0x47de99]
2: /lib64/libc.so.6 [0x3008032fe0]
3: /usr/bin/X(CopyKeyClass+0x75) [0x5366f5]
4: /usr/bin/X(mieqProcessInputEvents+0x2e3) [0x4ca1e3]
5: /usr/bin/X(ProcessInputEvents+0x9) [0x47ea09]
6: /usr/bin/X(Dispatch+0x71) [0x4471c1]
7: /usr/bin/X(main+0x3bd) [0x42ce8d]
8: /lib64/libc.so.6(__libc_start_main+0xe6) [0x300801e5c6]
9: /usr/bin/X [0x42c319]
Comment 4 Jan Martinek 2009-02-02 15:40:33 EST
Created attachment 330673 [details]
Xorg log with the backtrace
Comment 5 Jan Martinek 2009-02-03 12:59:16 EST
I have just tried to downgrade to older versions:

xorg-x11-drv-evdev-2.1.0-1.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-6.fc10.x86_64

and it works fine. Keys like XF86AudioRaiseVolume, XF86AudioLowerVolume, XF86Tools, XF86Calculator and others are correctly recognized by xev and the X server does not crash.
Comment 6 Per Thomas Jahr 2009-02-06 14:50:26 EST
Same problem with crash when testing F11 Alpha Live CD. Keyboard is Logitech diNovo Edge and I'm using the Intel graphics driver. I can always reproduce.

2.6.29-0.66.rc3.fc11.i686

I updated these two, but the multimedia keys still crashes X:
xorg-x11-drv-evdev-2.1.2-1.fc11.i386
xorg-x11-server-Xorg-1.5.99.902-3.fc11.i386
Comment 7 Adam Jackson 2009-02-08 02:33:57 EST
Jan's backtrace evaluates to this bit in CopyKeyClass:

        for (i = 0; i < 8; i++)
            mk->modifierKeyCount[i] = dk->modifierKeyCount[i];

I have to assume that turns into a libc call because the compiler is smart enough to call it a memcpy.  But that's about the extent of my knowledge of this code.

Passing the buck to Peter.
Comment 8 Peter Hutterer 2009-02-08 20:02:54 EST
Should be fixed with 1.5.99.902-5, can you please give it a test?
Comment 9 Per Thomas Jahr 2009-02-09 15:57:19 EST
Yes, that works. The crash is gone and all the multimedia keys works except that there is some trouble with volume up and down. 

Volume up: only raises the volume about 10% and then down to 0.
Volume down: instantly mutes volume.

Also, the slider in the volume control applet doesn't move when I use the up/down multimedia keys.

But maybe the volume problems should be in a new bug? If so, what component?
Comment 10 Jan Martinek 2009-02-10 04:28:40 EST
I confirm both things. Thank you for fixing the crash, now it is stable.

And it really seems that some multimedia keys have changed their meaning, but it is probably another issue. I will try to do some tests.
Comment 11 Peter Hutterer 2009-02-10 19:56:52 EST
Closing as RAWHIDE, please open a separate bug for the multimedia key issue.

Crash fixed with xorg-x11-server 1.5.99.902-5.

Note You need to log in before you can comment on or make changes to this bug.