Bug 483495 - xscreensaver-properties.desktop file breaks functionality with Xfce 4.6
xscreensaver-properties.desktop file breaks functionality with Xfce 4.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 15:57 EST by Wade Nelson
Modified: 2009-02-02 12:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 08:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Nelson 2009-02-01 15:57:42 EST
Description of problem:
From Xfce 4.6 onwards, Xfce relies on an xscreensaver .desktop file for showing the "Screensaver" configuration in its settings manager.  Since xscreensaver-properties.desktop contains the line OnlyShowIn=GNOME, xscreensaver-demo must be run from the command line to access xscreensaver settings in Xfce.

Version-Release number of selected component (if applicable):
xfce4-settings-4.5.99.1-1.fc10.i386 (built from rawhide SRPMS)
xscreensaver-5.08-5.fc10.i386

Additional info:
removing OnlyShowIn=GNOME remedies the issue.
Comment 1 Mamoru TASAKA 2009-02-01 23:18:52 EST
Are KDE people happy with this change?
Comment 2 Rex Dieter 2009-02-02 00:27:44 EST
ok by me.
Comment 3 Mamoru TASAKA 2009-02-02 08:58:10 EST
Okay, should be fixed in 5.08-7.fc11 (only changed in F-11,
won't change on <= F-10 unless XFCE team has a plan to update
<= F-10 XFCE to 4.6)
Comment 4 Kevin Fenzi 2009-02-02 12:14:35 EST
We may look at pushing 4.6 to F10 down the road, it will depend on when 4.6 final is released and how stable it's looking. 

In any case we can let you know when/if that happens. ;) 

Thanks for taking care of this so quickly.

Note You need to log in before you can comment on or make changes to this bug.