Bug 483514 - PA clients hang
PA clients hang
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 21:00 EST by jagginess
Modified: 2009-04-23 17:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Pulseaudio on FC10: this problem occured after yum upgrade.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 17:43:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jagginess 2009-02-01 21:00:02 EST
Description of problem:
Totem/alsamixer app/flash plugin, or related music players fail to start properly.
Disabling or turning of pulseaudio (user-started) daemon (start-pulseaudio-x11) fixes the issue.
The issue is that the program seems frozen(firefox stalls on the loading flash content, totem stalls, and alsamixer does not start)


alsamixer or totem exhibit this message when started from xterm,

"I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE
"



Version-Release number of selected component (if applicable):
pulseaudio 0.9.13


How reproducible:
yum upgrade
type alsamixer or totem from xterm

Steps to Reproduce:
1. yum upgrade
2. open firefox, and open a flashplugin webpage with audio content(or type alsamixer or totem in xterm)
3. to fix(gnome session): edit gnome session to not start pulseaudio server (or kill process running userstarted pulseaudio daemon)



Actual results:
-flash page freezes
-totem doesnt show its logo
-alsamixer stalls showing given message

Expected results:
obviously..

Additional info:
-This occurs on both kernels on my i386 32bit system. (yum upgrade installed a new kernel, and on either boot disabling this pulseaudio server allows my audios apps to start normally)
Comment 1 jagginess 2009-02-01 21:01:12 EST
yum upgrade was initiated with root privileges.. but my entire session is non-root
Comment 2 Lennart Poettering 2009-02-24 22:04:21 EST
This is probably because some application is blocking access to the audio device. PulseAudio hence cannot open it and all clients to it hang until PA can acecss it again.

Use fuser -v /dev/dsp* /dev/snd/* to find out which application this is.
Comment 3 Lennart Poettering 2009-04-23 17:43:11 EDT
Closing due lack of response.

Note You need to log in before you can comment on or make changes to this bug.