Bug 483520 - garbled displaying in ia64 arch for the zh_CN locale
garbled displaying in ia64 arch for the zh_CN locale
Status: CLOSED DUPLICATE of bug 139531
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox (Show other bugs)
4.8
All Linux
low Severity medium
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 23:52 EST by Vivian Bian
Modified: 2009-02-02 07:45 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 07:45:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the effect in i386 arch for Arabic (96.38 KB, image/png)
2009-02-01 23:58 EST, Vivian Bian
no flags Details
the effect in i386 arch for Chinese(Traditional) (105.21 KB, image/png)
2009-02-01 23:59 EST, Vivian Bian
no flags Details
the garbled Arabic in ia64 (93.76 KB, image/png)
2009-02-01 23:59 EST, Vivian Bian
no flags Details
the garbled Chinese (Traditional) in ia64 (95.65 KB, image/png)
2009-02-02 00:00 EST, Vivian Bian
no flags Details
the fonts installed in the ia64 arch (1.02 KB, text/plain)
2009-02-02 00:14 EST, Vivian Bian
no flags Details

  None (edit)
Description Vivian Bian 2009-02-01 23:52:54 EST
Description of problem:
visit the http://www.unicode.org/iuc/iuc10/x-utf8.html with the zh_CN locale in the ia64 arch,and there will be the garbled words displayed for the Arabic language and Chinese (Traditional) language

Version-Release number of selected component (if applicable):
firefox-3.0.6-1.el4 - ia64 (zh_CN)

How reproducible:
Always

Steps to Reproduce:
1.[In the terminal]
# LANG=zh_CN.UTF-8 firefox 
2.browse the  http://www.unicode.org/iuc/iuc10/x-utf8.html page ,and check the Arabic and Chinese (Traditional) language displayed in the page
Actual results:
the two language are displayed garbled

Expected results:
the Arabic and Chinese (Traditional) words could be displayed normally

Additional info:
the two language could be displayed well in i386 arch
Comment 1 Vivian Bian 2009-02-01 23:58:30 EST
Created attachment 330579 [details]
the effect in i386 arch for Arabic
Comment 2 Vivian Bian 2009-02-01 23:59:07 EST
Created attachment 330580 [details]
the effect in i386 arch for Chinese(Traditional)
Comment 3 Vivian Bian 2009-02-01 23:59:42 EST
Created attachment 330581 [details]
the garbled Arabic in ia64
Comment 4 Vivian Bian 2009-02-02 00:00:17 EST
Created attachment 330582 [details]
the garbled Chinese (Traditional) in ia64
Comment 5 Vivian Bian 2009-02-02 00:14:02 EST
Created attachment 330583 [details]
the fonts installed in the ia64 arch
Comment 6 Vivian Bian 2009-02-02 00:17:14 EST
what's more when load the http://www.joins.com page,there will also be the garbled displaying in the ia64 arch ,although the View->Character Coding->More Encodings->East Asian->Korean(EUC-KR) is checked
Comment 7 Matěj Cepl 2009-02-02 07:45:39 EST

*** This bug has been marked as a duplicate of bug 139531 ***

Note You need to log in before you can comment on or make changes to this bug.