Bug 483523 - Upgrade to version 2.3 fails due to dependency errors
Upgrade to version 2.3 fails due to dependency errors
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gallery2 (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On: 484566
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 02:21 EST by Bevis King
Modified: 2009-04-27 17:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.3-7.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 17:40:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bevis King 2009-02-02 02:21:19 EST
Description of problem:
When gallery2 is upgraded from 2.2 to 2.3 via the Fedora Updates channel, standard installations with minimal extensions fail due to a changed dependency.  The httpauth module is used by the standard system theme called matrix, and this has become part of a separate package called gallery2-httpauth which is not included in the upgrade.

When the upgrade package is installed, it causes the next invocation of gallery2 to pass through gallery's site upgrade script.  Once completed (apparently successfully), this links back to the gallery2 url which immediately fails with an "Error - There was an Error" message.  Enabling debug shows that it's trying to access the httpauth module set in modules/httpauth and failing because it is missing.

The problem is resolved by installing the gallery2-httpauth package.  It would seem that gallery2-httpauth should be a package dependency of the base gallery2 package in order to stop this upgrade breaking existing user installations.

Version-Release number of selected component (if applicable):
gallery2-2.3-1.fc10.noarch

How reproducible:
Unknown.

Steps to Reproduce:
1.  install gallery2 version 2.2 (installation default for Fedora 10)
2.  upgrade package to 2.3
3.  run gallery2's upgrade script
  
Actual results:
Existing gallery2 installation fails to work after upgrade.

Expected results:
After gallery2 upgrade script has reconfigured the gallery2 installation, the installation should work normally.

Additional info:
Adding gallery2-httpauth as a dependency on the gallery2 base package at the 2.3 release point should fix the problem.
Comment 1 Fedora Admin XMLRPC Client 2009-02-03 14:29:22 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Gwyn Ciesla 2009-02-04 16:05:21 EST
Fixed in rawhide, update in Bodhi created.
Comment 3 Fedora Update System 2009-02-04 21:22:00 EST
gallery2-2.3-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gallery2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1360
Comment 4 Fedora Update System 2009-04-13 14:02:12 EDT
gallery2-2.3-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gallery2-2.3-5.fc10
Comment 5 Gwyn Ciesla 2009-04-13 14:02:49 EDT
Should be fine now, please test.
Comment 6 Fedora Update System 2009-04-14 11:58:05 EDT
gallery2-2.3-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gallery2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3675
Comment 7 Fedora Update System 2009-04-21 09:28:33 EDT
gallery2-2.3-7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gallery2-2.3-7.fc11
Comment 8 Fedora Update System 2009-04-21 09:28:49 EDT
gallery2-2.3-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gallery2-2.3-7.fc10
Comment 9 Gwyn Ciesla 2009-04-21 09:29:43 EDT
Please test -7, about to hit -testing.
Comment 10 Bevis King 2009-04-21 10:38:02 EDT
Jon - I can't really help on this - since it's a dependency issue, since I installed the requisite dependency on my server, it's not going to exhibit the fault in the same way.  I don't have an old-version virgin machine to test the new package on.  Additionally my Gallery 2 database schema is now upgraded to the 2.3 level, so the same upgrade path won't get followed.  Sorry.  Regards, Bevis.
Comment 11 Gwyn Ciesla 2009-04-21 10:50:26 EDT
Ok.  I'll leave this open in case others see the same issues before -7 hits stable.
Comment 12 Fedora Update System 2009-04-21 20:47:52 EDT
gallery2-2.3-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gallery2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3754
Comment 13 Fedora Update System 2009-04-27 17:40:35 EDT
gallery2-2.3-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.