Bug 483526 - gmpc changes IP address in profiles, then fails to reconnect.
gmpc changes IP address in profiles, then fails to reconnect.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gmpc (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 03:00 EST by David Woodhouse
Modified: 2009-12-18 02:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:46:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-02-02 03:00:11 EST
I run mpd on my laptop, and use gmpc to connect to it.

I have a profile called 'localhost', and set the IP address to ::1 or 127.0.0.1.

However, gmpc seems to _change_ the IP address in its stored profile, picking up the IP address my laptop happens to have on its wired or wireless devices. This works only until the machine moves to another network, and then stops working -- gmpc can no longer connect to the local mpd, because it's picked up some bogus IP address for it rather than just trying to connect to localhost as I told it to.

This can only be fixed by going back into the configuration and correcting the IP address in the profile to be what I'd originally set it to.

I've worked around this for now by 'chattr +i ~/.gmpc/profiles.cfg'.
Comment 1 Adrian Reber 2009-02-07 14:01:09 EST
I am using following profiles.cfg and it stays the same:

[Default]
hostname="127.0.0.1"
portnumber="6600"
useauth="0"
name="localhost"
password=""

[2708980518]

name="main"
hostname="192.168.1.1"
portnumber="6600"
password=""
useauth="0"

The hostname for the "Default" profile always stays "127.0.0.1".

gmpc seems to not touch the "profiles.cfg" file if I do not edit the profiles. I have tested it with gmpc-0.16.1-1.fc10.i386.

Can you see if it changes the 127.0.0.1 on startup or on shutdown of gmpc.
Comment 2 David Woodhouse 2009-06-27 04:40:25 EDT
It changes shortly after startup (as long as mpd is actually running). It seems to be when it receives the mDNS notification.

It looks like this:

[Music Player on macbook.infradead.org]
name="localhost"
hostname="127.0.0.1"
password="xxxxx"
portnumber="6600"
useauth="1"
autoconnect="1"
[]


The '127.0.0.1' gets changed to _some_ current IP address of the host; whichever mpd is advertising.
Comment 3 Bug Zapper 2009-11-18 05:57:15 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2009-12-18 02:46:34 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.