Bug 483623 - Intel GMA4500 dvi/vga support
Intel GMA4500 dvi/vga support
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks: 590060 726826 668575
  Show dependency treegraph
 
Reported: 2009-02-02 11:43 EST by Alan Matsuoka
Modified: 2011-10-16 00:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-16 00:34:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport (2.90 MB, application/x-bzip2)
2009-02-02 11:43 EST, Alan Matsuoka
no flags Details
dmesg from sosreport (20.44 KB, text/plain)
2009-02-08 09:52 EST, Matěj Cepl
no flags Details
messages from sosreport (64.56 KB, text/plain)
2009-02-08 09:52 EST, Matěj Cepl
no flags Details
xorg.conf from sosreport (598 bytes, text/plain)
2009-02-08 09:52 EST, Matěj Cepl
no flags Details
Xorg.0.log from sosreport (30.74 KB, text/plain)
2009-02-08 09:52 EST, Matěj Cepl
no flags Details

  None (edit)
Description Alan Matsuoka 2009-02-02 11:43:48 EST
Created attachment 330647 [details]
sosreport

State the problem
The client have a Lenovo ThinkCentre M58p with a chipset q45 and a intel GMA 4500 video card. When using the Intel video driver his computer gets most of the time a blank screen and the cpu fans appears to increase to full speed. He is also experiencing what it appears to be the bug #476831.

1. Provide time and date of the problem
  N/A

2. Indicate the platform(s) (architectures) the problem is being reported against.
  rhel5.3 x86_64

3. Provide clear and concise problem description as it is understood at the time of escalation
  * Observed behavior
  The Intel driver is not able to use the DVI output only the VGA output works.
  When using the VGA output the system gets a blank screen and the cpu appears to get a peak since the fans get to full power.
  When using the vesa driver every thing works fine.
  * Desired behavior
  For the Intel driver to work with the DVI output and for the system to be able to properly display the video using the VGA connection.

4. State specific action requested of SEG
  Investigate that the DVI problem that is referred by the bug # 476831 is relevant.
  Verify what is causing the system to display the blank screen with the vga output.

5. State whether or not a defect in the product is suspected
  * Provide Bugzilla if one already exists
  bugzilla #476831

6. If there is a proposed patch, make sure it is in unified diff format (diff -pruN)
  N/A

8. This is especially important for severity one and two issues. What is the impact to the customer when they experience this problem?
  The client will be upgrading 20 desktops with this model during the first half of 2009 and need to be able to use a higher resolution then the ones that are available by the vesa driver.

SEG Notes:

This appears to be the same bug as IT 250320 /BZ 476831
Comment 1 Matěj Cepl 2009-02-08 09:52:05 EST
Created attachment 331238 [details]
dmesg from sosreport
Comment 2 Matěj Cepl 2009-02-08 09:52:14 EST
Created attachment 331239 [details]
messages from sosreport
Comment 3 Matěj Cepl 2009-02-08 09:52:19 EST
Created attachment 331240 [details]
xorg.conf from sosreport
Comment 4 Matěj Cepl 2009-02-08 09:52:25 EST
Created attachment 331241 [details]
Xorg.0.log from sosreport
Comment 5 Habig, Alec 2009-02-12 10:41:04 EST
Can confirm this bug on the same hardware.  Some more details:

The failure seems to occur on X start.  This has happened when booting from CD to install, when first entering runlevel 5, or when logging out and gdm restarts X.  Switching to the "vesa" X driver (rather than "intel") restores stability.  Minimal xorg.conf as generated by the install.

It is not a 100% thing.  The first machine I tried had about a 50% failure rate.  The one I'm trying to install now has worked once out of about 8 tries.  Smells like a race condition which might be hardware timing dependent.

When the driver fails, not only does the screen go black and the fans speed up to max, but the machine powers off.  Pretty hard - /var/log/messages lists the last thing happening as the desktop's gconfd exiting, then the restart when I reach over and power the box back on.  Yay for journaling file systems.

The fan speeding up thing is a lenovo bios feature, many lenovos ramp the fans to max speed temporarily upon power on as a functionality check, although this desktop model does not.  So I suspect that this is a red herring, unless it's a hint as to what BIOS call is being thwacked to cause the powerdown.

Is there a verbosity switch I could set on the intel driver that might shed more light on the situation?
Comment 6 RHEL Product and Program Management 2009-03-11 11:39:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Cameron Meadors 2009-04-21 08:36:12 EDT
QA_NAK 5.4

No capacity for this.
Comment 12 RHEL Product and Program Management 2010-08-09 14:53:01 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.