Bug 48363 - kernel 2.4.3-12 & sr_mod/ide-cd module: unresolved symbols
kernel 2.4.3-12 & sr_mod/ide-cd module: unresolved symbols
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-10 09:05 EDT by Christoph Hartmann
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 11:53:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Hartmann 2001-07-10 09:05:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
After kernel-update from 2.4.2-2 to 2.4.3-12 both ide-cd and sr_mod modules
could not be loaded anymore (unresolved symbols). Before the update both
modules worked (so it seems that it is not a general 2.4 issue...)

Since I have a IDE CD-RW I have to use the ide-scsi driver to get cdrecord
working (append="hdc=ide-scsi hdd=ide-scsi" line is available in
/etc/lilo.conf as well as some additional lines in /etc/modules.conf ).


How reproducible:
Always

Steps to Reproduce:
1. # modprobe ide-cd
2. # modprobe sr_mod


Actual Results:  1.:
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o: unresolved symbol
cdrom_get_last_written_Ra27af6fe
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o: unresolved symbol
cdrom_mode_sense_R8b5842d7
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o: unresolved symbol
init_cdrom_command_Rfacde1b5
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o: unresolved symbol
cdrom_mode_select_R35bf36d1
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o: unresolved symbol
unregister_cdrom_R47a75563
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o: unresolved symbol
cdrom_fops_R1d54b9e5
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o: unresolved symbol
register_cdrom_R4bfbf7de
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o: unresolved symbol
cdrom_number_of_slots_R7f072db8
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o: insmod
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o failed
/lib/modules/2.4.3-12/kernel/drivers/ide/ide-cd.o: insmod ide-cd failed

2.:
/lib/modules/2.4.3-12/kernel/drivers/scsi/sr_mod.o: unresolved symbol
unregister_cdrom_R47a75563
/lib/modules/2.4.3-12/kernel/drivers/scsi/sr_mod.o: unresolved symbol
cdrom_fops_R1d54b9e5
/lib/modules/2.4.3-12/kernel/drivers/scsi/sr_mod.o: unresolved symbol
register_cdrom_R4bfbf7de
/lib/modules/2.4.3-12/kernel/drivers/scsi/sr_mod.o: unresolved symbol
cdrom_number_of_slots_R7f072db8
/lib/modules/2.4.3-12/kernel/drivers/scsi/sr_mod.o: insmod
/lib/modules/2.4.3-12/kernel/drivers/scsi/sr_mod.o failed
/lib/modules/2.4.3-12/kernel/drivers/scsi/sr_mod.o: insmod sr_mod failed


Expected Results:  working sr_mod/ide-cd module


Additional info:

During system startup there is also a problem (kernel OOPS) regarding the
ide-cd module (called in /etc/rc.sysinit) but the system startup continues
normal after that:

Uniform CD-ROM driver unloaded
Unable to handle kernel NULL pointer dereference at virtual address
00000008
 printing eip:
c011a345
pgd entry df808000: 0000000000000000
pmd entry df808000: 0000000000000000
... pmd not present!
Oops: 0000
CPU:    0
EIP:    0010:[<c011a345>]
EFLAGS: 00010246
eax: 00000000   ebx: 00000000   ecx: 00000000   edx: 00000001
esi: df75d000   edi: 00000000   ebp: 00000000   esp: df821f7c
ds: 0018   es: 0018   ss: 0018
Process modprobe (pid: 197, stackpage=df821000)
Stack: e087a000 e087e5bb 00000000 e087e5fa 00000000 e0880240 c011792e
e087a000 
       df75d000 00000000 c0116e19 e087a000 00000000 df820000 00000000
0806a000 
       bfffeb28 c0106d2b 0806a000 0806a000 00000000 00000000 0806a000
bfffeb28 
Call Trace: [<e087a000>] [<e087e5bb>] [<e087e5fa>] [<e0880240>]
[<c011792e>] 
   [<e087a000>] [<c0116e19>] [<e087a000>] [<c0106d2b>]
Comment 1 Arjan van de Ven 2001-07-10 10:21:30 EDT
I tried to reproduce this and it works fine here.
This REALLY looks like your kernel modules and your kernel don't match!
Could you run
rpm --verify kernel

to see if any of the modules are strange ?

Comment 2 Christoph Hartmann 2001-07-10 13:13:01 EDT
sure, here it comes:

# rpm --verify kernel
S.5....T   /lib/modules/2.4.2-2/modules.dep
.......T   /lib/modules/2.4.2-2/modules.generic_string
.......T   /lib/modules/2.4.2-2/modules.isapnpmap
.......T   /lib/modules/2.4.2-2/modules.parportmap
S.5....T   /lib/modules/2.4.2-2/modules.pcimap
.......T   /lib/modules/2.4.2-2/modules.usbmap
.......T c /sbin/installkernel
S.5....T   /lib/modules/2.4.3-12/modules.dep
.......T   /lib/modules/2.4.3-12/modules.generic_string
.......T   /lib/modules/2.4.3-12/modules.isapnpmap
.......T   /lib/modules/2.4.3-12/modules.parportmap
.......T   /lib/modules/2.4.3-12/modules.pcimap
.......T   /lib/modules/2.4.3-12/modules.usbmap

The only additional thing I've done as far as I know (on both kernel versions) 
was a 'make config' inside /usr/src/linux-2.4.3 to get the bttv driver
compiling...
Comment 3 Christoph Hartmann 2001-08-18 15:20:24 EDT
Strange... After removing a few lines from /etc/modules.conf with a 
"depmod -a" afterwards) my CD-Writer/DVD works again...

I removed the following lines which worked (and where neccessary)
for kernels up to (and including) 2.4.2-2:

#options ide-cd ignore=hdc,hdd
#alias scd0 sr_mod
#alias scd1 sr_mod
#alias scsi_hostadapter ide-scsi
#pre-install sr_mod modprobe ide-scsi
Comment 4 Hasbullah bin Pit (sebol) 2001-12-08 08:14:25 EST
Woops... I think my bug related to my bug posted just now
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=57277
can hardy42 `dmesg |grep floppy` ?
Comment 5 Christoph Hartmann 2001-12-16 22:11:43 EST
sure...

# uname -a
Linux XXX 2.4.9-12 #1 Tue Oct 30 18:33:49 EST 2001 i686 unknown

#  dmesg | grep floppy
ide-floppy driver 0.97.sv
floppy interrupt on bizarre fdc 1
ide-floppy driver 0.97.sv

Note You need to log in before you can comment on or make changes to this bug.