Bug 483648 - kvm: Oops while installing rawhide/x86_64 guest on F-10/x86_64 host (__shrink_dcache_sb() BUG)
kvm: Oops while installing rawhide/x86_64 guest on F-10/x86_64 host (__shrink...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 14:01 EST by James Laska
Modified: 2013-09-02 02:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 14:05:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
guest.xml (1.17 KB, text/plain)
2009-02-02 14:01 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2009-02-02 14:01:05 EST
Created attachment 330664 [details]
guest.xml

Description of problem:

While installing a rawhide/x86_64 KVM guest on a F-10/x86_64 host using the e1000 NIC, the kernel oops.

Version-Release number of selected component (if applicable):
2.6.29-0.74.rc3.git3.fc11.x86_64

How reproducible:


Steps to Reproduce:
1. Start kickstart install of rawhide/x86_64 KVM guest
  
Actual results:

# virsh console vguest1

Welcome to Fedora for x86_64




     ┌─────────────────────┤ Package Installation ├──────────────────────┐
     │                                                                   │
     │                                                                   │
     │                                67%                                │      
     │                                                                   │      
     │                   361 of 448 packages completed                   │      
     │                                                                   │      
     │ ------------[ cut here ]------------.6.3-12.fc11.noarch (2 MB)    │      
kernel BUG at fs/dcache.c:473!olicy                                      │      
invalid opcode: 0000 [#1] SMP DEBUG_PAGEALLOC                            │      8: DeprecationWarning:last sysfs file: /sys/devices/virtual/block/dm-2/devnWarning: functions o│erriding warnings.showwarninCPU 0 st support the 'line' argument                                     │     warnings.warn(_("IgnoriModules linked in: ipv6 xts lrw gf128mul sha256_generic cbc dm_crypt dm_round_robin dm_multipath btrfs zlib_deflate libcrc32c xfs exportfs jfs reiserfs gfs2 msdos linear raid10 raid456 async_xor async_memcpy async_tx xor raid1 raid0 virtio_blk virtio_pci virtio_ring virtio e1000 iscsi_ibft iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ext2 ext4 jbd2 crc16 squashfs pcspkr edd floppy nfs lockd nfs_acl auth_rpcgss sunrpc vfat fat cramfs
Pid: 259, comm: kswapd0 Not tainted 2.6.29-0.74.rc3.git3.fc11.x86_64 #1
RIP: 0010:[<ffffffff810ed6fb>]  [<ffffffff810ed6fb>] __shrink_dcache_sb+0xd7/0x320
RSP: 0000:ffff88003a8d1ce0  EFLAGS: 00010283
RAX: 0000000000000000 RBX: ffff88000b572a40 RCX: 0000000000000035
RDX: ffff88000b573648 RSI: 0000000000000001 RDI: ffffffff815c7d00
RBP: ffff88003a8d1d40 R08: ffff88003c544fb8 R09: ffffffff810ed70b
R10: ffffffff8138383b R11: ffffffff810ed9fd R12: ffff88000b572ac0
R13: ffff88000b5735d0 R14: ffff880029976360 R15: ffff880029976560
FS:  0000000000000000(0000) GS:ffffffff81934000(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 00007fecc5753000 CR3: 000000000b052000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process kswapd0 (pid: 259, threadinfo ffff88003a8d0000, task ffff88003c544720)
Stack:
 ffff88003a8d1d64 0000005400000008 ffff8800198d9a20 ffff8800198b8c08
 ffff88000a8413b8 ffff88000b573648 0000000000000072 ffff880029976360
 0000000000000070 0000000000000072 0000000000000021 0000000000001096
Call Trace:
 [<ffffffff810eda35>] shrink_dcache_memory+0xf1/0x193
 [<ffffffff810b31be>] shrink_slab+0xe3/0x158
 [<ffffffff810b3997>] kswapd+0x4d7/0x69a
 [<ffffffff810b196a>] ? isolate_pages_global+0x0/0x220
 [<ffffffff8105f08c>] ? autoremove_wake_function+0x0/0x38
 [<ffffffff8106d7ae>] ? trace_hardirqs_on+0xd/0xf
 [<ffffffff810b34c0>] ? kswapd+0x0/0x69a
 [<ffffffff8105ed14>] kthread+0x49/0x76
 [<ffffffff8101262a>] child_rip+0xa/0x20
 [<ffffffff81011f3e>] ? restore_args+0x0/0x30
 [<ffffffff8105eca6>] ? kthreadd+0x176/0x19b
 [<ffffffff8105eccb>] ? kthread+0x0/0x76
 [<ffffffff81012620>] ? child_rip+0x0/0x20
Code: 89 51 08 4d 89 be 00 02 00 00 4d 89 be 08 02 00 00 e9 ec 01 00 00 4d 8b a6 08 02 00 00 49 8d 5c 24 80 4c 39 b3 d0 00 00 00 74 04 <0f> 0b eb fe 4c 8d 6b 08 4c 89 ef e8 84 62 29 00 83 7d a8 00 74 
RIP  [<ffffffff810ed6fb>] __shrink_dcache_sb+0xd7/0x320
 RSP <ffff88003a8d1ce0>
---[ end trace f3560f519f18ea3f ]---

Expected results:

 * no oops.

Additional info:

 * See attachment for guest xml info
Comment 1 Mark McLoughlin 2009-02-25 05:43:45 EST
It's hitting the BUG_ON() below

static void __shrink_dcache_sb(struct super_block *sb, int *count, int flags)
{
...
                while (!list_empty(&sb->s_dentry_lru)) {
                        dentry = list_entry(sb->s_dentry_lru.prev,
                                        struct dentry, d_lru);
                        BUG_ON(dentry->d_sb != sb);
...

Marcelo: could this be yet another pvmmu issue (bug #480822)? That fix only went in in -rc5.git1, whereas this is -rc3.git3
Comment 2 Marcelo Tosatti 2009-02-25 10:30:56 EST
The dentry cache is corrupted. It could be the pvmmu bug, but it could as well
be another source of corruption.

Please try -rc5.git so the pvmmu bug can be ruled out.
Comment 3 Marcelo Tosatti 2009-03-04 10:53:20 EST
James,

Can you please confirm the problem is not present on recent FC11 builds? Latest
kernel seems to be

kernel-2.6.29-0.197.rc7.fc11.x86_64.rpm

Thanks
Comment 4 James Laska 2009-03-04 14:05:27 EST
Marcelo ... indeed I am no longer seeing this issue.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.