Bug 48365 - eject CD-ROM mounted by automount used to work, now doesn't
eject CD-ROM mounted by automount used to work, now doesn't
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: eject (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-10 09:40 EDT by Jonathan Kamens
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-23 23:56:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-07-10 09:40:30 EDT
[jik@jik packages]$ eject
umount: /dev/cdrom mount disagrees with the fstab
eject: unmount of `/dev/cdrom' failed

I had to use "eject -p" to get it to eject the CD-ROM.  This behavior
appears to be new.  Automount and eject should play nicely together so that
eject can spit out CD-ROMs mounted by automount with no arguments.
Comment 1 Jonathan Kamens 2001-07-10 09:41:54 EDT
Hmm.  It just got worse.  Now "eject -p" is reporting "umount: only root can do
that".  It wasn't doing that before.
Comment 2 Ngo Than 2001-07-18 06:22:10 EDT
which version of eject do you have.
eject-2.0.9-2 in rawhide should fix this problem
Comment 3 Jonathan Kamens 2001-07-19 02:20:47 EDT
I have eject-2.0.9-2, and it just did it again:

> eject
umount: /dev/cdrom mount disagrees with the fstab
eject: unmount of `/dev/cdrom' failed
> 

When I waited a little bit and then ran it again, it worked (presumably because
the automounted had in the meantime unmounted the cd-rom).
Comment 4 Ngo Than 2001-08-06 08:29:17 EDT
It's not a bug. You should set correct timeout in /etc/auto.master.
Comment 5 Jonathan Kamens 2001-08-06 09:17:04 EDT
I don't understand.  This worked before.  It doesn't work now.  How can that not
be a bug?

I don't understand how this can be explained by reference to timeouts, because
I'm pretty certain that in previous versions of the software, I could "eject" a
CD-ROM immediately after accessing it with no trouble.  What has changed?
Comment 6 Jonathan Kamens 2001-08-10 11:43:51 EDT
I am reopening this bug because I would like an explanation of why it is not
considered a bug if it worked before and it doesn't now.  I used to be able to
eject a CD mounted by autofs without mucking with any timeouts, when it was
still mounted by autofs.  I can't do that anymore.
Comment 7 Ngo Than 2001-09-20 13:13:53 EDT
It should be a bug autofs or mount.
Could you please update autofs-3.1.7-21 and mount-2.11g-5. restart autofs
service again after update. It should work.

It works for me.
Comment 8 Jonathan Kamens 2001-09-23 23:56:09 EDT
I am becoming irritated by the runaround I'm getting about this bug.

I already have autofs-3.1.7-21 and mount-2.11g-5 installed.  My /etc/auto.master
looks like this:

/misc   /etc/auto.misc  --timeout=60

My /etc/auto.misc looks like this:

cd              -fstype=iso9660,ro,nosuid,nodev :/dev/cdrom

I just put a RedHat Linux OS CD in the drive and typed "ls /misc/cd".  I got a
listing as I expected, i.e., the CD was automounted.  Then I immediately typed
"eject" and got:

umount: /dev/cdrom mount disagrees with the fstab
eject: unmount of `/dev/cdrom' failed

I repeat my assertion -- this used to work and now it doesn't.  That makes it a
bug.
Comment 9 Ngo Than 2001-09-26 07:57:09 EDT
i can reproduce this problem. if you do 'ls /misc/cd' automount mounts it as
root. If you try to do eject as normal user it does not work, because you are
not allow to do that. It's correct so.

If you add 'dev/cdrom   /misc/cd  iso9660 noauto,owner,kudzu,ro 0 0' into
/etc/fstab, a normal user can umount this device and it should work for you.
Comment 10 Alexei Podtelezhnikov 2001-09-26 17:16:46 EDT
If automount mounts CD inserted by user as root, this is somewhat strange...
What's the problem with mounting it as user on 0:0?

Note You need to log in before you can comment on or make changes to this bug.