Bug 483692 - pc98_probe() hangs
pc98_probe() hangs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 20:54 EST by David Cantrell
Modified: 2009-02-11 15:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-11 15:54:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Cantrell 2009-02-02 20:54:07 EST
While working on the new pyparted, the system kept entering an infinite loop or crash of some sort.  Tracked it down to pc98_probe() in libparted/labels/pc98.c

The block the appears to be running in an infinite loop is:

/* check consistency */
empty = 1;
for (p = part_table.partitions;
     p < part_table.partitions + MAX_PART_COUNT;
     p++)
{    
    if (p->mid == 0 && p->sid == 0)
        continue; 
    empty = 0;
    if (!check_partition_consistency (dev, p))
        return 0;
}

For now I am just using a locally built libparted with --disable-pc98 so that I can keep going working on pyparted and syntax changes to anaconda.
Comment 1 Joel Andres Granados 2009-02-06 13:14:17 EST
I've tested with upstream parted and can't see the issue.  My test consisted of getting the dev `dev = parted.getDevice("DEVICE")` and getting the disk `disk = parted.Disk(dev)`  With each (dev and disk) I pocked around and nothing failed.  Do you have a python script that shows the failure?  Additionally, its not out of the realm of possibility that the partition lay out might have something to do with this.  Can you also post what your partition looks like so I can make the test more accurate.  I think whatever `parted -l` spits out will be enough.
Comment 2 Chris Lumens 2009-02-11 15:54:41 EST
We are no longer seeing this in testing pyparted.  Perhaps it was never really a bug to begin with?

Note You need to log in before you can comment on or make changes to this bug.