This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 483694 - Bluetooth does not work on Dell Latitude D630
Bluetooth does not work on Dell Latitude D630
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-02 21:14 EST by Rui Matos
Modified: 2013-01-10 02:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:47:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lsusb -v output (9.25 KB, text/plain)
2009-02-02 21:14 EST, Rui Matos
no flags Details
hciconfig -a output (604 bytes, text/plain)
2009-02-02 21:15 EST, Rui Matos
no flags Details
dellWirelessCtl --info output (1.47 KB, text/plain)
2009-02-02 21:16 EST, Rui Matos
no flags Details

  None (edit)
Description Rui Matos 2009-02-02 21:14:35 EST
Created attachment 330702 [details]
lsusb -v output

Ok, so I have a Dell Latitude D630 running F10. It has a blutooth device but it just doesn't work. There's the little gnome applet thing running but it does nothing. I'm just dumping all the info I can think of about it as attachments.

I've tried to add

options btusb reset=1

to /etc/modprobe.conf and also to run

$ sudo hciconfig hci0 reset

and none of those worked. I still get

$ hcitool scan
Scanning ...
$

i.e. nothing, while I'm sure I've got my phone bluetoothing along with other PC (running a proprietary OS) nearby. None of those can see my laptop either.

Probably relevant software versions:

bluez-4.22-2.fc10.i386
gnome-bluetooth-0.11.0-5.fc10.i386
bluez-cups-4.22-2.fc10.i386
gnome-bluetooth-libs-0.11.0-5.fc10.i386
bluez-gnome-1.8-11.fc10.i386
bluez-libs-4.22-2.fc10.i386
bluez-alsa-4.22-2.fc10.i386

kernel-PAE-2.6.27.12-170.2.5.fc10.i686
Comment 1 Rui Matos 2009-02-02 21:15:47 EST
Created attachment 330703 [details]
hciconfig -a output
Comment 2 Rui Matos 2009-02-02 21:16:28 EST
Created attachment 330704 [details]
dellWirelessCtl --info output
Comment 3 Rui Matos 2009-02-02 21:30:46 EST
From this post

http://marc.info/?l=linux-bluetooth&m=123229162921771&w=2

it seems this is yet another case of an uncooperative hardware vendor?

Some more info as requested by Marcel Holtmann on that mail:

$ sudo bccmd buildname
Build name: cyt_8unified_fl_bt2.0_kymodo_21d_0702212310_encr56 2007-02-21

$ sudo hciconfig hci0 revision
hci0:	Type: USB
	BD Address: 00:1A:6B:C5:25:F2 ACL MTU: 310:10 SCO MTU: 64:8
	Build 4315
	Chip version: BlueCore4-External
	Max key size: 56 bit
	SCO mapping:  HCI
Comment 4 Rui Matos 2009-04-19 17:08:12 EDT
Is there anything else I can do about this? I was going to report it upstream but couldn't find a bug tracker on the bluez project's website.

I've tested the latest Fedora 11 Snapshot 1 and it didn't work there either.
Comment 5 Rui Matos 2009-07-08 14:09:33 EDT
Hi Matthew, I thought I could just add you in CC for this bug. Hopefully it won't just go unoticed in your bugzilla mail.
Comment 6 Bug Zapper 2009-11-18 04:47:59 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2009-12-18 02:47:24 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.