Bug 483722 - Certain sound files are only audible when PulseAudio Volume Control window is opened
Certain sound files are only audible when PulseAudio Volume Control window is...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 05:55 EST by Dawid Lorenz
Modified: 2009-07-29 22:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 22:06:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example sound file which is affected by this problem. (1020 bytes, audio/x-wav)
2009-02-03 05:55 EST, Dawid Lorenz
no flags Details

  None (edit)
Description Dawid Lorenz 2009-02-03 05:55:39 EST
Created attachment 330723 [details]
Example sound file which is affected by this problem.

Description of problem:
After installing the latest batch of system updates, some sound files are not played correctly, unless I open a PulseAudio Volume Control window in the background. Then these files are audible OK.

It does seem to affect Totem (with gstreamer background) and applications like Pidgin, where I have custom wav file set up to indicate new messages (attached). However, Rhythmbox seems to be not affected by this issue.

Version-Release number of selected component (if applicable):

[root@m4300 ~]# rpm -qa | grep pulseaudio
pulseaudio-module-x11-0.9.14-1.fc10.i386
pulseaudio-esound-compat-0.9.14-1.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
pulseaudio-0.9.14-1.fc10.i386
pulseaudio-utils-0.9.14-1.fc10.i386
pulseaudio-libs-glib2-0.9.14-1.fc10.i386
pulseaudio-module-gconf-0.9.14-1.fc10.i386
pulseaudio-libs-0.9.14-1.fc10.i386
pulseaudio-core-libs-0.9.14-1.fc10.i386


How reproducible:
Try play attached file with Totem. File would seem to be played OK, but there is no sound. Then open PulseAudio Volume Control window and try again. It will sound OK.

Steps to Reproduce:
As above.
  
Actual results:
Can't hear any sound when PAVC window is not open.

Expected results:
Sound file should played nevertheless of PAVC window.

Additional info:
It does happen on two different machines, both after installing the latest system updates.

As stated above, however, it does not seem to affect Rythmbox at all.
Comment 1 markm 2009-02-03 06:09:56 EST
I can confirm this bug on my machine,

attached file is audible when PulseAudio Volume Control window is open only.

it may be related to another bug I've spotted - when I play movies / videos, first couple of seconds are quiet and or with noise and crackles, then audio is fine. I've just tested and when PAVC is open, there is no silence / noise or crackles when video playback starts.
Comment 2 Lennart Poettering 2009-07-29 22:06:04 EDT
I am pretty sure this got fixed in F11 (0.9.15) . Closing now. If it didn't get fixed, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.