Bug 483731 - anaconda does not properly handle existed raid devices in kickstart
anaconda does not properly handle existed raid devices in kickstart
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 07:38 EST by Peter Vrabec
Modified: 2011-07-27 13:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-27 13:20:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2009-02-03 07:38:36 EST
Description of problem:
Image the situation where you have existed system and you want to re-install it via kickstart. You don't want to make any changes with partitions, because it's desired to use EXISTED partitions and raid devices. Some raid devices should be formatted(/boot") some not(/home). And now the problem is: that even even if you properly use onpart  and useexisted options in your kickstart, the existed raid devices are ignored by installer.


Example:

Lets reinstall system like this. Installation is driven by kickstart without users interaction - everything already set-up in kickstart
/dev/md0 - /boot --format
/dev/sda3 -/     --format
/dev/sda4 - swap --format
/dev/md1 - /home --NO_format

After successful installation reboot into the system and see mount and /etc/fstab.

Result:
Neither /boot nor /home is mounted

Expected result:
/boot mounted and re-formatted
/home mounted and not-formatted (useexited)

Additional info:
There might be a problem with my kickstart. And I'll be happy it that's the true. But I have tried several kickstarts created by different ways(hand/anacodna/system-config-,...) and none of them worked.
Comment 1 Hans de Goede 2009-11-30 06:03:45 EST
Can you please attach the kickstart file in questions and the installation logs?

Note You need to log in before you can comment on or make changes to this bug.