Bug 483732 - rhn-satellite-activate prints error about certificate version mismatch, but activates anyway
rhn-satellite-activate prints error about certificate version mismatch, but a...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
511
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Michael Mráka
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-02-03 07:51 EST by Christian Jung
Modified: 2010-10-23 03:26 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:32:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Jung 2009-02-03 07:51:36 EST
Description of problem:
If you try to activate a Satellite with a certificate which was created for a different version, this should print an error message and not continue.

But in fact, rhn-satellite-activate prints an error message and activates the Satellite anyway.

Version-Release number of selected component (if applicable):
rhns-satellite-tools-5.1.1-16.noarch 

How reproducible:
always

Steps to Reproduce:
1. create a Satellite certificate for RHNS 5.2
2. setup a RHNS 5.1 Server 
3. activate it with a 5.1 certificate and connect your RHNS 5.1 to rhn.redhat.com
4. reactivate the satellite with the 5.2 certificate
  
Actual results:
ERROR: RHN Entitlement Certificate cannot be imported - the versions of current and new certificate do not match, [5.1] vs. [5.2]
Please rerun with --ignore-version-mismatch if you want to override this test.

Check rhn.redhat.com and you will notice, that your Satellite is now subscribed to RHNS 5.2 channel.

Expected results:
rhn-satellite-activate should not change the channel in RHN

Additional info:
- The error message printed by rhn-satellite-activate raises the impression, nothing was changed - but in fact the Satellite channel changed.
- This might lead to a corrupt Satellite because by applying Erratas the system is mixing RPMs taken from RHNS 5.1 and 5.2.
- This exactly happened for one customer which (in combination with other issues) led to a corrupt Satellite.
- I did not use --ignore-version-mismatch
- I only tried a RHNS 5.1 with a 5.2 certificate
Comment 3 Malte Menkhoff 2009-02-13 06:30:39 EST
Additional informations:
the customer done the procedure via certificate substitution on rhn.redhat.com.
the re-enactment with satellite 5.1.1 and satellite 5.2 certificate.
rhn.redhat.com gave no error message or anything else to the customer.
this is always reproducible.
the subcripted channel changed from 5.1 to 5.2 and a following up2date updated the package set of the satellite to a mix of 5.1 + 5.2 packages.
Comment 5 Malte Menkhoff 2009-02-16 15:39:29 EST
is this also fixed if you will activate the certificate in rhn.redhat.com ?
Comment 8 Brandon Perkins 2009-09-10 16:32:32 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.