Bug 483756 - Wrong usage of ghn_errno and strerror_r
Wrong usage of ghn_errno and strerror_r
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 09:27 EST by Masatake YAMATO
Modified: 2009-11-06 19:19 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.3-44
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 533323 (view as bug list)
Environment:
Last Closed: 2009-11-06 19:19:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch fixing the issue. (1.33 KB, patch)
2009-02-03 09:27 EST, Masatake YAMATO
no flags Details | Diff

  None (edit)
Description Masatake YAMATO 2009-02-03 09:27:12 EST
Created attachment 330729 [details]
A patch fixing the issue.

Description of problem:

When unexisting host name is given, automount reports following message to log
  automount[2234]: create_udp_client: hostname lookup failed: Operation not permitted

because gethostbyname_r is failed. However, in this case, this message should be
  automount[2234]: create_udp_client: hostname lookup failed: Unknown host

Broken message comes from sterror_r(ghn_errno,...); See the patch for more detail.
  
Version-Release number of selected component (if applicable):

  autofs-5.0.3-36

How reproducible:

 This report is just based on code-reading. So I cannot tell the way. Sorry.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ian Kent 2009-02-03 09:50:23 EST
OK, will fix.
Comment 2 Fedora Update System 2009-11-06 00:27:46 EST
autofs-5.0.3-44 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/autofs-5.0.3-44
Comment 3 Fedora Update System 2009-11-06 19:19:40 EST
autofs-5.0.3-44 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.