Bug 483767 - default puppet.conf does not support pluginsync
default puppet.conf does not support pluginsync
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: puppet (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 10:13 EST by Kjetil T. Homme
Modified: 2013-04-30 19:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 22:55:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjetil T. Homme 2009-02-03 10:13:24 EST
Description of problem:
The recommended method for distributing plugins and facts does not work out of the box with the EPEL packaged puppet.conf.  This complicates bootstrapping since a replacement puppet.conf must be distributed prior to the first Puppet run if the configuration relies on custom facts or providers.

Version-Release number of selected component (if applicable):
puppet-0.24.7-4.el5

Additional info:

This URL has the background:
http://reductivelabs.com/trac/puppet/wiki/PluginsInModules

The fix is pretty simple, add this to puppet.conf:

[main]
pluginsync = true
factpath = $vardir/lib/facter
Comment 1 Todd Zullinger 2009-05-31 22:21:00 EDT
This seems like something that we should follow upstream on.  I think it would be worth asking on puppet-dev or puppet-users why these settings are not enabled by default.  Kjetil, would you care to ask about this on one of those lists?
Comment 2 Todd Zullinger 2009-07-07 22:55:05 EDT
I don't think this should be considered a bug.  If this should be enabled by default, it should be something that upstream agrees with and ships in the stock configuration.

Note You need to log in before you can comment on or make changes to this bug.