Bug 483777 - lot of undefined-non-weak-symbol with festival
lot of undefined-non-weak-symbol with festival
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: festival (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 10:51 EST by Nicolas Chauvet (kwizart)
Modified: 2011-03-14 18:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 242607
Environment:
Last Closed: 2011-03-14 18:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmlint on installed festival package (50.60 KB, application/octet-stream)
2009-02-03 10:51 EST, Nicolas Chauvet (kwizart)
no flags Details

  None (edit)
Description Nicolas Chauvet (kwizart) 2009-02-03 10:51:35 EST
Created attachment 330741 [details]
rpmlint on installed festival package

+++ This bug was initially created as a clone of Bug #242607 +++

--- Additional comment from kwizart@gmail.com on 2009-01-22 11:53:33 EDT ---

Created an attachment (id=329721)
undefined-non-weak-symbol_festival-lib-1.96-7.fc10.x86_64.log

There are lot of undefined-non-weak-symbol_festival
in the festival-lib-1.96-7.fc10 package (running rpmlint fastival-lib on installed package).

Theses symbols should be added at link time and could be the reason of runtime failures when the needed libraries aren't present at runtime. It will also prevents the linker to preload suches libraries which will degrade performances when loading. (since every symbol will be revolved at runtime).
Comment 1 Tim Niemueller 2009-05-13 07:29:23 EDT
What's the reasoning for closing this as WONTFIX?
Comment 2 Nicolas Chauvet (kwizart) 2009-05-13 07:33:36 EDT
please don't loose time with undeed talks,
 either fix it or not... But I won't spend time of fix it myself.

I don't want to have this in my buglist
Comment 3 Matthew Miller 2009-05-13 07:48:33 EDT
reopening. this will *eventually* be fixed.
Comment 4 Nicolas Chauvet (kwizart) 2011-03-14 18:05:39 EDT
festival-1.96-18.fc14.x86_64 doesn't have the problem

Note You need to log in before you can comment on or make changes to this bug.