Bug 483789 - Kernel fails to insert PCMCIA cards
Kernel fails to insert PCMCIA cards
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-02-03 11:37 EST by Chris A
Modified: 2009-02-04 13:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-02-04 13:23:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg produced after inserting 3 different pcmcia (42.27 KB, text/plain)
2009-02-03 11:37 EST, Chris A
no flags Details

  None (edit)
Description Chris A 2009-02-03 11:37:32 EST
Created attachment 330748 [details]
dmesg produced after inserting 3 different pcmcia

Description of problem:

I am trying to configure a newly installed Fedora 10 on a Dell 630C laptop, Intel Core 2 Duo Processor with 4 GB of RAM. 
Problem occurs when inserting a new peripheral in PCMCIA slot. The kernel seems to see properly the card, but fails to load driver for any pcmcia I'm trying to plug in. 
I did also try to boot in single mode, but it also fails. I guess that the problem could be coming from Fedora 10 kernel (but not sure), as inserting cards works perfectly on other distribution (debian,backtrack,...). 

Version-Release number of selected component (if applicable):

I have tried this operation on kernel :

How reproducible:

Steps to Reproduce:
1. insert pcmcia card
2. watch dmesg
Actual results: depends on what card are inserted: cards are seen, but fail to load. Several pcmcia cards were tried and produced dmesg sent in attachment.
Those cards are:
- 3Com PCI 3CCFE575CT Tornado CardBus
- Atheros AR5213A chip device 
- QualComm 3G CDMA CardBus card

Additional info:
(see dmesg in attachment)
Comment 1 Chuck Ebbert 2009-02-03 21:58:12 EST
The drivers are all loading just fine:

pccard: CardBus card inserted into slot 0
PCI: 0000:04:00.0 reg 10 32bit mmio: [0, ffff]
AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133)
ath_pci 0000:04:00.0: enabling device (0000 -> 0002)
ath_pci 0000:04:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
MadWifi: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
ath_pci 0000:04:00.0: PCI INT A disabled
pccard: card ejected from slot 0

The driver loaded, reported that it doesn't support that revision of the card, and unloaded. (And we don't provide or support that driver.)

The nozomi driver for the Qualcomm card loads and reports everything is fine.

The 3Com network driver loads and reports that the Ethernet address on the card is invalid. The card may be broken or some other bug might be present but the PCMCIA system is loading the driver correctly.

Note You need to log in before you can comment on or make changes to this bug.