Bug 483792 - [RFE]: add "Delete all" button while partitioning
[RFE]: add "Delete all" button while partitioning
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: AnacondaStorage
  Show dependency treegraph
 
Reported: 2009-02-03 11:54 EST by Karel Volný
Modified: 2009-09-30 11:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 11:21:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2009-02-03 11:54:42 EST
Description of problem:
During RHEL installation, when it comes to partitioning disk drives, you can select "Create custom layout." Then you can customize the layout to your needs, however at first you have to get rid off the old layout. If you want to start from scratch and remove all the old partitions, if the old layout is not trivial, it is very inconvenient to repeatedly select the right partition, click "Delete", click "Delete" again in the confirmation box, then select another partition ... especially if there was some LVM setup (which is default) and you have to choose things to delete in a particular order (which you have to figure out at first).

Not a big issue, but surely it would make some poor souls condemned to repeat manual installations happier ;-)
Comment 2 Chris Lumens 2009-05-26 11:34:32 EDT
I don't think we'll be able to get to this in a RHEL5 update release given the number of customer requests and bug fixes coming in, but we certainly should take a look for RHEL6.  We've already got a lot of UI changes planned for that release.
Comment 3 Denise Dumas 2009-06-30 16:42:24 EDT
Moving to RHEL6 so it doesn't get mistakenly closed by the bot
Comment 5 RHEL Product and Program Management 2009-06-30 17:08:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Joel Andres Granados 2009-09-08 09:29:40 EDT
I see some issues with this approach:

1. Implementing this button is asking for trouble.  Imagine a enterprize setup where you have tens of drives.  The user might shoot himself in the foot and erase one of the drives that he wants to keep.

2. Number of buttons in the customization GUI.  We currently have 6 buttons.  Adding a seventh would complicate stuff.  Its one more thing to think about when you are doing the customization.

3. Using Jeremy's approach (comment#4), the process is not so bad.  Additionaly, one can also delete a Volume Group with all its related LV.
Comment 7 Hans de Goede 2009-09-30 11:14:09 EDT
Devel nacking this for the reasons listed in comment #6
Comment 8 RHEL Product and Program Management 2009-09-30 11:21:42 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.