Bug 483820 - xorg-x11-drv-keyboard gets every keystroke in triplicate (when "AllowEmptyInput" is "no")
xorg-x11-drv-keyboard gets every keystroke in triplicate (when "AllowEmptyInp...
Status: CLOSED DUPLICATE of bug 467636
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-keyboard (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 14:09 EST by Michal Jaegermann
Modified: 2009-02-08 10:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-08 10:20:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf used in trials (873 bytes, text/plain)
2009-02-03 14:09 EST, Michal Jaegermann
no flags Details
Xorg.0.log when AllowEmptyInput is set to "no" (43.17 KB, text/plain)
2009-02-03 14:12 EST, Michal Jaegermann
no flags Details
Xorg.0.log when AllowEmptyInput is set to "yes" (41.43 KB, text/plain)
2009-02-03 14:12 EST, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2009-02-03 14:09:23 EST
Created attachment 330765 [details]
/etc/X11/xorg.conf used in trials 

Description of problem:

With the following in xorg.conf

Section "ServerFlags"
        Option "AllowEmptyInput" "no"
EndSection

every key press sends a corresponding character three times.  Makes it an interesting proposition to login through gdm, although a console does not have any issues and one can get to graphic session via startx where the same fun continues.  Backspace removes three characters too so it is not of much help.
Turning off "Key presses repeat when key is held down" does not change that.

With "AllowEmptyInput" set to "yes" one gets "Disabling Keyboard0", typing comes through evdev device and the problem disappears.

Version-Release number of selected component (if applicable):
xorg-x11-drv-keyboard-1.3.2-1.fc11

How reproducible:
every time I tried
Comment 1 Michal Jaegermann 2009-02-03 14:12:13 EST
Created attachment 330766 [details]
Xorg.0.log when AllowEmptyInput is set to "no"
Comment 2 Michal Jaegermann 2009-02-03 14:12:58 EST
Created attachment 330767 [details]
Xorg.0.log when AllowEmptyInput is set to "yes"
Comment 3 Matěj Cepl 2009-02-08 10:20:03 EST
This is misconfiguration and duplicate of bug 467636.

*** This bug has been marked as a duplicate of bug 467636 ***

Note You need to log in before you can comment on or make changes to this bug.