This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 483839 - Topic changes get truncated at cursor position
Topic changes get truncated at cursor position
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xchat-gnome (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-03 15:49 EST by Paul W. Frields
Modified: 2009-07-04 23:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.26.1-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 15:54:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 536916 None None None Never

  None (edit)
Description Paul W. Frields 2009-02-03 15:49:50 EST
xchat-gnome-0.24.1-1.fc10.x86_64

When I change topic using the Alt-T window shortcut, and hit [Enter] to activate the default "Change" action, the [Enter] isn't trapped, so the topic is truncated at the current cursor position.  So if I'm writing a topic and edit it thus, where the '|' character represents the cursor:

I want this topic |to be complete

When I hit [Enter], the topic will be changed to "I want this topic ".  The [Enter] key should probably be trapped in some way since there's no point in inserting a blank line in a channel topic as far as I know. (But I could be wrong.)
Comment 1 ritz 2009-05-09 21:16:17 EDT
patch posted to upstream.
Comment 2 Fedora Update System 2009-05-10 08:13:31 EDT
xchat-gnome-0.24.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xchat-gnome-0.24.1-2.fc10
Comment 3 Fedora Update System 2009-05-12 00:00:36 EDT
xchat-gnome-0.24.1-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xchat-gnome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4761
Comment 4 Fedora Update System 2009-05-29 22:34:43 EDT
xchat-gnome-0.24.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-06-21 19:50:33 EDT
xchat-gnome-0.26.1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xchat-gnome-0.26.1-3.fc11
Comment 7 Fedora Update System 2009-06-21 20:14:19 EDT
xchat-gnome-0.24.1-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xchat-gnome-0.24.1-3.fc10
Comment 8 Fedora Update System 2009-06-24 15:27:10 EDT
xchat-gnome-0.26.1-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xchat-gnome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6797
Comment 9 Fedora Update System 2009-07-03 15:49:25 EDT
xchat-gnome-0.24.1-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-07-03 15:54:32 EDT
xchat-gnome-0.26.1-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Jens Petersen 2009-07-04 23:11:40 EDT
Thank you - this was biting me for a long time :-)

Note You need to log in before you can comment on or make changes to this bug.