Bug 483881 - java-1.6.0-openjdk-plugin doesn't provide pluginappletviewer
Summary: java-1.6.0-openjdk-plugin doesn't provide pluginappletviewer
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: java-1.6.0-openjdk
Version: el5
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-02-04 05:05 UTC by Paul Bransford
Modified: 2009-07-16 00:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-04 06:47:08 UTC
Type: ---


Attachments (Terms of Use)

Description Paul Bransford 2009-02-04 05:05:07 UTC
Description of problem:

The package java-1.6.0-openjdk-plugin doesn't provide pluginappletviewer to firefox. This means that when a java applet would run, firefox instead throws an error.

The line of interest from firefox (in debug mode):
gcjwebplugin.cc:1045: thread 0x7673d10: Error: Failed to spawn applet viewer: Failed to execute child process "/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/../../bin/pluginappletviewer" (No such file or directory)

I've searched under all of /usr/lib/jvm, so this pluginappletviewer isn't existing from the default RHEL5.3 or the openjdk packages.


How reproducible:
100% - I can't get it to NOT happen

Steps to Reproduce:
1. Install RHEL 5.3
2. Install EPEL
3. Install openjdk packages
4. Attempt to use a java applet in Firefox
  
Actual results:
Error dialog, applet is not run

Expected results:
Applet runs

Additional info:

Installed Packages
Name       : java-1.6.0-openjdk-plugin
Arch       : x86_64
Epoch      : 1
Version    : 1.6.0.0
Release    : 1.0.b12.el5.2
Size       : 27 k
Repo       : installed
Summary    : OpenJDK Web Browser Plugin
URL        : http://icedtea.classpath.org/
License    : GPLv2 with exceptions
Description: The OpenJDK web browser plugin.

Name       : firefox
Arch       : x86_64
Version    : 3.0.5
Release    : 1.el5_2
Size       : 14 M
Repo       : installed
Summary    : Mozilla Firefox Web browser.
URL        : http://www.mozilla.org/projects/firefox/
License    : MPLv1.1 or GPLv2+ or LGPLv2+
Description: Mozilla Firefox is an open-source web browser, designed for
           : standards compliance, performance and portability.

Comment 1 Lubomir Rintel 2009-02-04 06:47:08 UTC
Won't fix this, since the EPEL package is obsolete as Red Hat includes OpenJDK in RHEL 5.3. Unfortunatelly, they did not agree on NVR being lower.

Please note that packages shipped by Red Hat don't contain the browser plugin at all. The EPEL package may eventually be replaced with plugin-only package in future.

If you want the gcjwebplugin functionality for OpenJDK, install the java-1.6.0-openjdk-devel package from EPEL.

Comment 2 D. E. Evans 2009-07-16 00:32:34 UTC
> If you want the gcjwebplugin functionality for OpenJDK, install the
> java-1.6.0-openjdk-devel package from EPEL.

This is not accurate (i.e. gcjwebplugin is not in -devel):

$ rpm -ql java-1.6.0-openjdk-devel | grep gcj
$

A "yum whatprovides '*gcjwebplugin*'" does not produce results, either.


Note You need to log in before you can comment on or make changes to this bug.