Bug 483892 - Restart GDM on login screen reboot OS
Restart GDM on login screen reboot OS
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 02:03 EST by jarki
Modified: 2015-01-14 18:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 10:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jarki 2009-02-04 02:03:29 EST
Description of problem:

If you select 'Restart GDM' on Fedora login screen, it reboots Fedora.
It should restart GDM, not restart OS.
Pressing CTRL+ALT+Backspace works as expected.

Version-Release number of selected component (if applicable):

Fedora 10 with and without the latest updates.
gdm-2.24.0-12.fc10.

How reproducible:


Steps to Reproduce:
1. Install Fedora 10 normally. Apply the latest updates if you wish.
2. On the login screen press 'Restart GDM' button.
3. The OS reboots.
  
Actual results:

The Fedora reboot.

Expected results:

Only the GDM should reboot.


Additional info:
Comment 1 jarki 2009-02-05 01:15:39 EST
Not sure if ctrl-alt-backspace work either because if I change display manager and then press ctrl-alt-backspace to try restart X, the display manager doesn't change. You have to reboot OS to take effect another display manager.
Comment 2 Ray Strode [halfline] 2009-02-09 09:52:32 EST
There is no restart-gdm button, there is only a restart-your-system button (next to a suspend-your-system button and a shutdown-your-system button)
Comment 3 jarki 2009-02-09 13:42:08 EST
Yes, true - when you choose system English language, you can see buttons
Suspend - Restart - Shutdown
But when you switch to Finnish, the English 'Restart'-button is translated 
'Käynnistä GDM uudelleen" (in english: Restart GDM), which is wrong - it should be 'Käynnistä järjestelmä uudelleen'.

Seems this is a localization bug.
Comment 4 rh 2009-07-20 10:38:09 EDT
This seems to be fixed in F11, hence closing the bug.

Note You need to log in before you can comment on or make changes to this bug.