This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 483914 - debuginfo-install has no memory to keep debug packages synced parent upgrades
debuginfo-install has no memory to keep debug packages synced parent upgrades
Status: CLOSED DUPLICATE of bug 432806
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 03:27 EST by Dwayne Bailey
Modified: 2014-01-21 18:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 09:20:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dwayne Bailey 2009-02-04 03:27:35 EST
Description of problem:
-debuginfo packages installed to help debugging are tied to the actual applications RPM. While debuginfo-install is a great way to get these installed they are often out of date when you actually need them rendering your crash traceback unusable.

Version-Release number of selected component (if applicable):
1.1.19

Steps to Reproduce:
1. Run your app say evolution till it crashes
2. No debug info so someone recommends you install them and you use debuginfo-install.  Next time you'll catch that horrid bug
3. Aha Evolution crashes again
4. Your debuginfo is out of date since evolution was upgraded between crashes
5. GOTO 1. and repeat
  
Actual results:
You more often then not end up with out of date debuginfo that renders your wonderfully caught bug report useless.

Expected results:
Once you have installed a debug package it should stay in sync when the parent package is updated, until you remove debuginfo for that package.  This might not be a task for debuginfo-install or for yum-utils but I'm not sure where else to put it.

The world I'd like to see if one in which packages for update and checked to see if they have debuginfo installed. If they do then update of the debuginfo for them is automatically enabled when you install a new release.

You end up with a system that always has the info it needs for the packages that you want to ensure has bug info.
Comment 1 seth vidal 2009-02-04 09:20:02 EST

*** This bug has been marked as a duplicate of bug 432806 ***

Note You need to log in before you can comment on or make changes to this bug.