Bug 484056 - gtk-window-decorator: ghost-like title bars... (really)
gtk-window-decorator: ghost-like title bars... (really)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
: 484596 (view as bug list)
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-02-04 10:28 EST by Tom London
Modified: 2009-12-30 14:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-01 04:07:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of "active" window showing botched decoration (77.98 KB, image/png)
2009-02-04 10:28 EST, Tom London
no flags Details
Better screenshow of "ghost-like" window decorations (48.10 KB, image/png)
2009-02-05 10:07 EST, Tom London
no flags Details
/var/log/Xorg.0.log from session with "ghost-like" title bars (31.16 KB, text/plain)
2009-02-08 11:54 EST, Tom London
no flags Details
~/.xsession-errors generated with "ghost-like" title bar (93.30 KB, text/plain)
2009-02-08 11:55 EST, Tom London
no flags Details
Window without decorations.... (33.77 KB, image/png)
2009-02-18 10:21 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2009-02-04 10:28:09 EST
Created attachment 330872 [details]
Screenshot of "active" window showing botched decoration

Description of problem:
With recent rawhide updates, I've the window title bars have been replaced by "grey ghosts" that do not have the names of the windows.  I attach an example ....

If I disable desktop effects, I get nice blue title bars ....  Re-enabling compiz makes them go away.

See lots (thousands!) of the following spew in ~/.xsession-errors:

(gtk-window-decorator:6281): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed

(gtk-window-decorator:6281): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed

(gtk-window-decorator:6281): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed

(gtk-window-decorator:6281): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed



Version-Release number of selected component (if applicable):
[tbl@tlondon ~]$ rpm -qa compiz\*
compiz-debuginfo-0.7.8-12.fc11.x86_64
compiz-0.7.8-12.fc11.x86_64
compiz-fusion-extras-gnome-0.7.8-5.fc11.x86_64
compiz-gnome-0.7.8-12.fc11.x86_64
compizconfig-python-0.7.8-2.fc11.x86_64
compiz-fusion-0.7.8-5.fc11.x86_64
compiz-fusion-gnome-0.7.8-5.fc11.x86_64
compiz-fusion-extras-0.7.8-5.fc11.x86_64
[tbl@tlondon ~]$ 


How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-02-05 10:07:56 EST
Created attachment 330992 [details]
Better screenshow of "ghost-like" window decorations

Realized previous screenshot didn't show title bar....
Comment 2 Matěj Cepl 2009-02-08 10:45:37 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Tom London 2009-02-08 11:54:11 EST
Created attachment 331245 [details]
/var/log/Xorg.0.log from session with "ghost-like" title bars

Xorg.0.log attached.

No /etc/X11/xorg.conf.

System is Thinkpad X200, Intel graphics, rawhide, running kernel-2.6.29-0.93.rc3.git10.fc11.x86_64.

Not requested, but I'll also attach ~/.xsession-errors.

Here are current versions of some (relevant?) packages:

[tbl@tlondon ~]$ rpm -qa xorg-x11-server\* xorg-x11-drv-i810 compiz\* mesa\* \*drm\* 
mesa-libGL-7.3-0.4.fc11.x86_64
mesa-libGLU-devel-7.3-0.4.fc11.x86_64
libdrm-2.4.4-4.fc11.x86_64
mesa-libGL-devel-7.3-0.4.fc11.x86_64
compiz-debuginfo-0.7.8-12.fc11.x86_64
compiz-0.7.8-12.fc11.x86_64
xorg-x11-server-common-1.5.99.902-3.fc11.x86_64
mesa-dri-drivers-7.3-0.4.fc11.x86_64
compiz-fusion-extras-gnome-0.7.8-5.fc11.x86_64
libdrm-devel-2.4.4-4.fc11.x86_64
compiz-gnome-0.7.8-12.fc11.x86_64
xorg-x11-server-Xorg-1.5.99.902-3.fc11.x86_64
libdrm-debuginfo-2.4.4-1.fc11.x86_64
compizconfig-python-0.7.8-2.fc11.x86_64
xorg-x11-drv-i810-2.5.99.1-0.3.fc11.x86_64
mesa-debuginfo-7.3-0.4.fc11.x86_64
compiz-fusion-0.7.8-5.fc11.x86_64
compiz-fusion-gnome-0.7.8-5.fc11.x86_64
mesa-libGLU-7.3-0.4.fc11.x86_64
compiz-fusion-extras-0.7.8-5.fc11.x86_64
xorg-x11-server-utils-7.4-4.fc11.x86_64
[tbl@tlondon ~]$
Comment 4 Tom London 2009-02-08 11:55:29 EST
Created attachment 331247 [details]
~/.xsession-errors generated with "ghost-like" title bar

~/.xsession-errors with lots of :

(gtk-window-decorator:3325): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed

(gtk-window-decorator:3325): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed

(gtk-window-decorator:3325): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed
Comment 5 Erik van Pienbroek 2009-02-08 14:17:31 EST
I'm also having this problem on a nVidia GeForce 8600M GS (with the nvidia driver)
Comment 6 Tom London 2009-02-18 10:21:54 EST
Created attachment 332387 [details]
Window without decorations....

This continues with latest rawhide.

Not window decorations.....

Messages in ~/.xsession-errors:

(gtk-window-decorator:3299): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed

(gtk-window-decorator:3299): metacity-CRITICAL **: meta_frame_style_draw_with_style: assertion `style_gtk->colormap == gdk_drawable_get_colormap (drawable)' failed
Comment 7 Will Woods 2009-02-25 23:17:55 EST
Confirmed here as well.
Comment 8 Adel Gadllah 2009-02-28 15:36:32 EST
Should be fixed in compiz-0.7.8-14.fc11

It should hit rawhide soon, or try the build from koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=91911
Comment 9 Tom London 2009-02-28 20:31:32 EST
Indeed!

compiz-0.7.8-14.fc11.x86_64
compiz-gnome-0.7.8-14.fc11.x86_64

fix this for me.

Thanks!
Comment 10 Hamidou Dia 2009-12-30 14:08:45 EST
*** Bug 484596 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.