Bug 484091 - Incorrect CFLAGS in libical.pc
Incorrect CFLAGS in libical.pc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libical (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 13:03 EST by Matthew Barnes
Modified: 2009-03-25 12:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 00:11:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to fix CFLAGS in libical.pc. (421 bytes, patch)
2009-02-17 00:05 EST, Debarshi Ray
no flags Details | Diff
Fix headers too (5.62 KB, application/octet-stream)
2009-03-15 13:36 EDT, Debarshi Ray
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 569459 None None None Never

  None (edit)
Description Matthew Barnes 2009-02-04 13:03:36 EST
Evolution recently merged to upstream libical, but we're having to work around an issue in libical's pkg-config file.

#include <ical.h> gives you a deprecation warning and tells you to #include <libical/ical.h> instead.  But the CFLAGS provided by libical.pc don't support this:

   $pkg-config --cflags libical
   -I/usr/include/libical  

With this, #include <libical/ical.h> fails because there's no such file /usr/include/libical/libical/ical.h.

The CFLAGS should include "-I/usr/include".
Comment 1 Rex Dieter 2009-02-04 13:17:34 EST
pkg-config will never return /usr/include, since that's a default include dir.

(Not that I'm arguing against -I/usr/include/libical being wrong).
Comment 2 Debarshi Ray 2009-02-17 00:05:28 EST
Created attachment 332171 [details]
Proposed patch to fix CFLAGS in libical.pc.
Comment 3 Fedora Update System 2009-03-13 14:37:26 EDT
libical-0.43-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2009-03-13 14:43:02 EDT
libical-0.43-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Debarshi Ray 2009-03-15 13:36:16 EDT
Created attachment 335265 [details]
Fix headers too

We also need to fix some of the #includes in libical-devel to make things work with our CFLAGS.
Comment 6 Fedora Update System 2009-03-15 15:10:42 EDT
libical-0.43-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libical-0.43-4.fc10
Comment 7 Fedora Update System 2009-03-15 15:13:38 EDT
libical-0.43-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/libical-0.43-4.fc9
Comment 8 Fedora Update System 2009-03-25 12:02:03 EDT
libical-0.43-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-03-25 12:14:36 EDT
libical-0.43-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.